Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old 2.5" IDE hard drive taking off Acer Ferrari 4000. I set a password for the hard-drive in BIOS. Laptop broke now I have only the hard drive - I remember the password.

Yet, I tried putting the hard-drive to another laptop (Thinkpad A21m) but it didn't recognize the hard-drive and complained about "no hard drive found". I also asked in a computer repair shop and the technician told me he would try to reset the password in his old laptop (acer or asus) but it didn't recognize the hard drive either.

I have a usb box for the hard drive so when I remove the password I'm OK to go.

Any ideas what to try next? I was thinking about buying an old acer laptop and after getting my data donating the laptop to oxfam though I'd prefer more straight forward solution.

Edit: As far as i can remember it said "no hard drive found" - big red message ove the whole screen.

or it will not work until you send it the password in a way it expects it. (E.g. using a similar laptop)

Yes, that's exactly what i think the problem is (it could be defect as well :-( ). And yes, I am afraid Acer support won't be very helpful.

(I can not add comments, so answering by adding a new answer)

I was also thinking about getting 2.5" IDE to 3.5" IDE adaptor and testing in a desktop but given the above Acer is probably using their own non-standard way to un/lock the hard drive :-(

share|improve this question

migrated from serverfault.com Mar 4 '12 at 18:46

This question came from our site for professional system and network administrators.

1  
I can't answer your question, but as an advice: always make good backups :) –  Lucas Kauffman Mar 4 '12 at 18:43
    
Even a harddrive with a password should be detected by the BIOS. Double check all settings, jumpers, etc. If still no go, then it sounds like the drive is broken. –  techie007 Mar 4 '12 at 18:48
    
@techie007: not necessarily - i think thinkpad will boot up only with "ibm approved" hard drives –  Lukas Mar 4 '12 at 20:18
1  
@Lukas you need to associate your SU and SF account, please stop posting comments as answers –  Ivo Flipse Mar 4 '12 at 21:00
add comment

1 Answer

Does it say "No hard drive found" or "No bootable device found"?

In the first case either the HDD defect, or it will not work until you send it the password in a way it expects it. (E.g. using a similar laptop). Acer might be able to help you with this, though getting support for such old hardware might be a challenge.

In the second case the drive contents might be encrypted. As a result you are not getting a valid MBR when you try to read the drive. Thus booting fails, but the drive is OK.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.