Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Basically after a while that my pc is running, photoshop (5.1, 64bit, on windows 7) will become unable to create new files or open existing ones, rebooting the computer seems to fix it, for a while, but then it gets back to "dumb" mode.

The problem seems to be affecting the 32bit version as well. Fireworks works fine tho.

Any idea how to fix it?


Create new file-> nothing happens. Nothing. Open file-> I can browse for the file, select it, and nothing happens.

I set up all 4 of my hard disks as scratch. Ram usage is highly variable, even if I close every other application, the error remains.

share|improve this question
3  
How exactly is it "unable to create or open"? What happens when you create a new file? Where does it fail? Do you get an error message? Same thing for opening files. Please add more details. – slhck Mar 4 '12 at 19:08
    
^ yup, need input. You could check your memory available in task manager, and check the "scratch disk" locations in the photoshop preferences. Also you could check the ammount of memory that it sets aside in preferances. – Psycogeek Mar 5 '12 at 1:05
    
I answered with the details, but nothing new around here. – Madness Mar 9 '12 at 4:05
    
I'm having this exact problem now -- started out of nowhere -- were you able to fix it? – Sherwin Yu May 14 '13 at 9:49
    
I'm using CS6 and have the same problem. PC uptime is 4 days, but I've had it up for 2 weeks without a problem. PS uses about 100k memory at best and just silently fails when you do "new document" or "open document". – Kyle Baran Dec 14 '15 at 18:43

This problem still occurs in 2015 and I decided to share the fix that works for me: -Create new file -Set size and hit OK -hit CTRL + BREAK couple of times DONE

https://forums.adobe.com/thread/1303390?start=40&tstart=0 Read the answer from Aug 27, 2015

share|improve this answer
    
If you have a laptop with switched Ctrl and Fn keys in BIOS looks like you should hit the key with word Ctrl have been printed on, not you reprogrammed Fn that works like a Ctrl. At least it worked for me on lenovo thinkpad. – Cheslab 2 days ago

Close Photoshop.  Then hold Command+Option+Shift (Control+Alt+Shift on PC) while you restart Photoshop.  This brings up a dialogue box where you can choose to delete your settings file.  This resolves lots of problems, and is worth trying before reinstalling.

share|improve this answer

By the way, as a temporary workaround, try this:

Edit - Preferences - Performance. Uncheck [ ] Enable OpenGL Display. Close and restart Photoshop.

Remember to turn OpenGL back on after you update your display driver, or you'll be without the OpenGL-specific features.

share|improve this answer

Try creating or opening a file in Illustrator, then on the file menu, choose edit in Photoshop. I tried a number of suggestions, but this one was the only one that worked for me. After creating and opening two files in Illustrator then editing them in Photoshop, now Photoshop opens and creates the files I tell it to.

share|improve this answer

I was experiencing this exact problem for quite a while (Photoshop CS4 64-bit on Win7 64-bit) and tried all kinds of things to fix it, fiddling with every remotely-relevant Photoshop setting there was, along with various Windows compatibility options, none of which made any difference.

In the end I tried completely uninstalling my (ATI/AMD Radeon HD 5670) graphics card drivers from Device Manager, forcing Windows 7 to revert to using its own built-in drivers (the ones listed in Device Manager as provided by "ATI Technologies Inc.", dated 9th November 2010 and with version 8.792.0.0). I've now been running everything with that driver for the past month and haven't had any more problems with Photoshop since then.

Clearly, reverting to stock graphics drivers is far from ideal if you use that computer to play games or anything like that, but as this is my work PC, the built-in driver works perfectly for my purposes.

(Of course, this could just be yet another one of the myriad solutions that people have found to fix this issue but which don't work for anyone else! Hopefully this will help at least one other person, though...)

Edit: Curses, Photoshop's just gone back to refusing to do anything. I'm beginning to wonder if this is an issue with faulty RAM or something, but for now all I can say is that reverting my graphics drivers doesn't seem to have solved the problem after all.

share|improve this answer

Try re-installing the application, it should resolve your problem. The correct way to do this is uninstalling Photoshop, reset the computer and then installing Photoshop again. Also check the "Run as administrator" in the properties menu, that seems to resolve a lot of problems as well, especially in Windows Vista/7/8.

share|improve this answer

I had this problem with PS CS5 and CS6. Nothing fixed the problem, resets, restores, reinstall etc., until I discovered a problem with my USB default printer. Windows for some reason had failed to recognize it correctly, despite it having been used happily for years (an update was probably the culprit). I reinstalled the printer and bingo, Photoshop started working again.

As an aside, I had problems with Word and printers a while back - Word wouldn't start if there was a disconnected networked default printer. I looks like PS is equally as sensitive to default printers. Check out your printers before messing with PS.

share|improve this answer

I had this problem for years, in both CS4 and CS5, on XP and Windows 7, (32 & 64 bits).. The only cure that works for me is to restart the computer and then hit "ctrl alt shift" to reset photoshop settings. Although it's still annoying for me to have to restart the computer.

Why Adobe doesn't fix this bug ? Is it some planned obsolescence to make sure you get the new CS after a while ?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .