Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Sony VAIO VPCCW27FX laptop.

The History

It works fine (Windows 7 x64; no driver issues of any kind; has latest BIOS), except with a slight glitch:
Sometimes, it won't shut down/hibernate/standby properly. Instead, it goes into a "coma":

  • The "power" and the "wireless" LEDs are on, but all the other LEDs are off
  • There is no HDD activity whatsoever
  • The display is completely off
  • The fan is on
  • The keyboard doesn't do anything: Ctrl-Alt-Delete doesn't do anything. Furthermore, I've even installed a driver to intercept Alt-SysRq-B and reboot the machine, but that doesn't work either
  • The power button doesn't do anything (normally, it shuts down the machine)

The only option I have when this happens is to hold the power button to force the machine to turn off, and then turn it on again. (When it is turned off forcefully like this, it takes a little longer for the BIOS to initialize, presumably because of additional tests it runs.)

This has happened whether or not the computer is plugged in, so it doesn't seem to be battery-related.

The Problem

Since last night, my laptop has suddenly gone into this "coma" three times, and each time, I wasn't there to observe it when this happened. (I only came back to see it not working.) It used to happen very rarely, but it surprised me when this happened so often.

Furthermore, it didn't seem like a hibernate/shut down/standyby problem anymore: Today morning, it happened in a timespan of less than 10 minutes while plugged in (I wasn't there to see it...), which is weird because the Standby and Hibernate timeouts are set to a few hours, and the "Turn off display" and "Dim display" settings are both is set to greater than 10 minutes. (Edit: Actually, I might've messed that up -- the "Dim Display" setting could have been less. But I can't reproduce the problem. :)

So I'm a little stumped... I haven't seen it happen on other versions of Windows (e.g. XP) or on Ubuntu, but I haven't used them often enough to notice this, anyway.

Any ideas what might be causing this?

share|improve this question
    
In XP I could look into system's log and check the events, I haven't found that in w7 yet. –  ott-- Mar 4 '12 at 21:16
    
@ott--: Unfortunately I don't see anything in there (other than a "Critical" event saying the shutdown was unexpected.) Thanks for the idea though. –  Mehrdad Mar 5 '12 at 6:59
add comment

2 Answers

Firstly I would like to point out that the issue you are experiencing is indeed not related directly to the Windows powersaving settings. This sort of blacking out appears to be a malfunction with the device itself, and as such it may be quite difficult to find the exact cause for this behavior.

There are some steps that you could take in order to eliminate possible faults though. 1, 2 and 3 for basic diagnostic work you may have partly done already, and 4 & 5 as possible solutions I can think of at this time without being able to have a look at the laptop itself.

  1. Run the computer without the battery, only using the powersupply/cable provided with the computer and see if this blacking out reoccurs then. History has a record of faulty battery level indicators and systems related to these functions that have caused obscure problems in laptops, even if it isn't the likeliest of causes.

  2. Disconnect any attached devices and cables excluding the powercord before you close the lid, let the computer go to standby, and re-open it a few times to see if the problem will occur with no additional devices. Many laptops provide power to USB-interfaces for example even in standby mode, it could be a long shot but doesn't hurt to try.

  3. Check that the powersaving/ACPI -settings in BIOS are on their default values if the BIOS version supports viewing and/or changing them. If they have been at default settings all along, you may want to disable powersaving features completely to test if the problem persists if possible. Not all laptop BIOSes give the user the option to adjust these settings, but if yours does, it's worth a look.

  4. This may sound strange, but my own HP Pavilion dv7-3113 had the exact same issue a while back, and I never determined the exact cause, as it stopped randomly falling into powered coma as quickly as it started doing so. What is common with these laptops is the same OS-version, so you may want to consider installing the latest batch of updates and see if the problem persists. If none of these steps solve the problem any further, there is also one thing that I personally found out, the mobile internet device I was using as a shared interface for other computers made it much more likely for the laptop to malfunction if the other computers were still using the interface. While the likelyhood did increase, there is no direct link to saying the network arrangement is to blame.

  5. Finally, if not a single thing mentioned above affects the issue even a bit, you may want to consider taking your laptop to be looked at by a computer service company, or warranty-service if the computer has valid warranty left. Laptops are at times prone to failures of the electronic components they contain. While this might not completely render the computer unusable, it could cause it to perform strangely. Even if the problem turned out to be caused by something else, a professional should be able to locate and fix the problem with being able to examine the computer up close.

share|improve this answer
    
+1 for the thorough list. I can't reproduce the problem deterministically, but I'll try the suggestions and see how they go. Thanks! –  Mehrdad Mar 5 '12 at 4:15
add comment
up vote 0 down vote accepted

I found the cause of the problem...

The problem started happening more often recently, so I was able to reproduce the problem and checked the Event Log for when the problem occurred, seeing that I was getting:

Display driver nvlddmkm stopped responding and has successfully recovered.

and sometimes also

: The embedded controller (EC) did not respond within the specified timeout period. This may indicate that there is an error in the EC hardware or firmware or that the BIOS is accessing the EC incorrectly. You should check with your computer manufacturer for an upgraded BIOS. In some situations, this error may cause the computer to function incorrectly.

That narrowed it down quite a bit for me, since I used to think it was the wireless...

Then I searched on the internet for the NVIDIA error, and came across this page, with people mentioning if my card was "overclocked".

Why, funny you should mention it, I thought... I've indeed enabled PowerMizer manually (i.e. through registry settings), to force it to run at a "medium" clock speed... ("Low" was too slow, and "high" used too much power.)

Hmmm so I tried disabling PowerMizer altogether, and the standby/resume worked perfectly! Then I re-enabled PowerMizer, and the sleep/resume took a long time... so I knew this must be the cause.

It's important to note, though: I had done this for a year already, with each version of the driver that was released. It probably therefore wasn't the mere fact that I'd enabled PowerMizer, but probably a driver bug in combination with that, since I had updated my driver recently.

Moral of the story:

  1. It's likely to be a graphics issue.

  2. If you enable settings manually... that might be the cause.

Troubleshooting was kinda fun/easy though, once it was reproducible anyway. :)

Hope that helps others of you out there.

Note:

I just re-tested: it works fine on older versions of the driver, so it's due to a driver bug.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.