Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In one of my systems, when I drag and drop a file it does not honor the pressing of the control key.

That is, when dragging in the same drive, it always moves files and does not copy them. And when dragging over a different drive, it always copies files.

Why is explorer exhibiting this behavior?

After more testing. Here is more information.

Sequence number 1

  1. Press CTRL key
  2. Click with left button over the filename on explorer
  3. Drag file (a plus (+) sign appears over the icon while dragged)
  4. move mouse over destination and release mouse button
  5. The file appears in destination and disappears in source. It MOVES, doesn't copy.

All the times I repeat sequence number 1 the result is the same. Independent of source and destination.

But if after sequence 1 I hold the CTRL key pressed (that is, I don't release the key and press it again) and repeat the sequence from point 2...

  1. keep Ctrl pressed
  2. Click with left button over the filename on explorer
  3. Drag file (a plus (+) sign appears over the icon while dragged)
  4. move mouse over destination and release mouse button
  5. The file now COPIES !!!

It also happens with the ALT key. Sequence 1 moves the file. And sequence 2 creates a shortcut.

share|improve this question
2  
Could you provide the version of Windows you are running? Has this happened since installation of the system, or did it start recently? –  Bob Mar 5 '12 at 10:09
    
XP Professional SP3. It started some weeks ago. I am not aware of any change in configuration I made. –  PA. Mar 5 '12 at 10:51
    
Does this only apply to Ctrl/copy or is Alt/link and Shift/move also affected? Do your modifier keys behave normally in other applications? Do you use any Explorer extensions (like QTTabBar)? –  Oliver Salzburg Mar 5 '12 at 11:37
    
See my EDIT. I don't have any explorer extension. –  PA. Mar 5 '12 at 12:29
    
Or maybe you think you don't have any. Check using ShExView just in case. There have been cases of secret extensions installed just to block copying... Although the simpler explanation, as in Oliver's answer, might actually be correct? –  grawity Mar 5 '12 at 13:06
show 2 more comments

4 Answers

I always use right-click drag'n'drop.
That way, on releasing the file @ destination, I get a neat menu where I can choose to Copy, Move, Create Shortcut, or Cancel the operation.
Works for all versions of Windows...

share|improve this answer
    
Thanks for the suggestion, I think I will try to get this habit. –  PA. Mar 5 '12 at 13:48
    
Same here, I cannot operate with the guess method, dont even have to hold any key down once you start the drag. I could not train myself back out of that method. might be very hard for a user to train into it. There is a possibility that some other program or driver , or even the driver the input device is useing itself is messing with the system seeing the qualifyer. Does it happen after a full restart of the computer? Specific "parallels" the program had this fault one time. –  Psycogeek Mar 5 '12 at 13:50
    
When pressing CTRL/ALT/SHIFT, Windows tells in the icon what it is doing. –  Nasenbaer Mar 5 '12 at 14:14
add comment
up vote 2 down vote accepted

As suggested, I am answering my own question, once I found a solution.

While testing I noticed that in this system the Shift Control and Alt keys were performing somewhat weird. A short research pointed to the sticky keys function (an accessibility option for people with limited motion) as a possible explanation for this strange (at least strange to me) behavior. I checked and it turned out that the keyboard was set in StickyKeys mode. Turning off this feature solved the copy/move issue.

However, the question remains for anyone that requires this option on and wants to copy a file by dragging it with Explorer.

share|improve this answer
    
Does tapping the Ctrl key and letting go before you release the mouse button work? Because that would be the sticky key equivalent of holding down Ctrl while you drag-n-drop. –  Lèse majesté Mar 5 '12 at 16:48
    
No, it doesn't. It seems that for the ctrl-drag operation the key is neither sticky nor normal. It is easily reproducible, just go to Control Panel > Accessibility Options> Keyboard > Use sticky keys –  PA. Mar 5 '12 at 17:10
    
I just tried it (I turned on Sticky Keys by tapping Shift 5 times), and it seems to work for me. If I drag and drop from the desktop to an explorer window, it only moves. However, if I tap Ctrl before letting go of the mouse button, a little noise (sticky Ctrl indication) will go off and the file icon will show the "+ Copy to..." label, and when I release the mouse button, a copy is created with the original remaining on the desktop. Afterwards, I can tap Ctrl again to release the sticky key. –  Lèse majesté Mar 5 '12 at 17:28
add comment

In Windows, when you drag files over a different drive, even without the Ctrl key pressed, it will always copy a file over the different drive while leaving a copy at the original drive.

In the same drive, drag on drop without any key pressed will resulting in moving the files while different behavior occurs when you press a modifier key.

share|improve this answer
    
You don't answer my question on why when pressing Ctrl key the files are still moved and never copied. –  PA. Mar 5 '12 at 10:54
add comment

If you hold the "CTRL" Key while releasing the mouse key, the files will be "Copied" on all my systems.

  • CTRL = COPY
  • SHIFT = MOVE
  • ALT = CREATE LINK

If you will NOT press any key on your keyboard, the files system expect that you will not move the files but copy to another drive by default. If the system is NOT ALLOWED to delete the source file for moving it because of permission of system or user permission, it will not delete the file but copy it. You cannot change this automated intelligence of Copy/Move in Windows Explorer. Just use the Keys on keyboard.

SOLUTION * Just use Teracopy. It will replace default Explorer copy window and will allow to show permission problems after copy.

http://codesector.com/teracopy

Regards

share|improve this answer
    
I think the problem is that the user does press the button, but it behaves as if he didn't. –  Daniel Beck Mar 5 '12 at 9:42
    
The problem is the "permission" of deleting as I wrote (I've edited some seconds later) –  Nasenbaer Mar 5 '12 at 9:43
3  
The user is aware of the keyboard modifiers you explained, and is pressing Ctrl. The files aren't copied on the same drive, but moved. The behavior of Explorer is the same as if he didn't press any button. How is this related to missing delete permissions if it's not copying? –  Daniel Beck Mar 5 '12 at 9:46
    
thanks Daniel. This is exactly my problem. It only happens in ONE system. All others work well. In the failing system, Explorer ALWAYS move the file, independently either or not I press Control. –  PA. Mar 5 '12 at 9:50
    
Creat for dowvoting!! Now you've updated the question. Holy,... that way I am not interested to answer anymore! –  Nasenbaer Mar 5 '12 at 14:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.