Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running an Ubuntu server guest on Win 7 guest, and am running a webrick server (RoR dev).

If I have just a host-only network, everything works fine and the browser response is instant. However, if I add a second network (NAT), so that the server can connect to the internet (for various updates etc.), the host-to-guest access gets really slow. I can't use the bridge connection.

I am using the port 3000 (RoR Webrick server) and connecting to the guest via internet browser on this port (eg http://192.168.56.102:3000).

Any idea, what could be causing this? If I ping the IP from host console, I get < 0ms.

Here are the settings (relevant info is in english; Povoleno vše is Everything is allowed):

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

share|improve this question
up vote 1 down vote accepted

I found an answer that works on Jose Gonzalvo's site:

Edit the value in ~/.rvm/rubies/ruby-1.9.X-pXXX/lib/ruby/1.9.X/webrick/config.rb from:

:DoNotReverseLookup => nil,

to

:DoNotReverseLookup => true,

Many thanks to Jose for the answer!

share|improve this answer
    
Yay, thanks a ton. – mreq Apr 21 '12 at 11:57
    
I'm not using rvm, but found the config file in /usr/lib/ruby/1.9.1/webrick/config.rb. Is there a way to make this change without editing a global config file? – Martin Vilcans Nov 23 '12 at 9:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .