Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At work, I have several Word 2007 macros in a Normal.dotm template. Under Windows XP, I had some of the macros assigned to keyboard shortcuts, e.g. Ctrl+Shift+9. Everything worked perfectly.

Our IT department recently gave me a new laptop with Windows 7 64-bit. The security settings on this new machine are much more restricted.

When I press my macro keyboard shortcuts, the macros don't execute. I am running as an Admin. I don't completely understand the security model under Windows 7. Despite being an Admin, there is apparently another admin level for running applications. I've tried setting the Privilege Level of WinWord.exe to "Run this program as an administrator" (on the Properties Compatibility tab), but no success.

I can run the macros directly through the macro dialog or by creating a toolbar icon. My macro security level is "Disable all macros except digitally signed macros".

In Excel, using macro shortcut keys works fine.

Any thoughts on what the problem might be?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I found a solution. As stated before, my macros were defined in Normal.dotm. They were in a code module named Module1.

I created a new module named Module2 then cut & pasted all the macros into this new module. After that, hotkeys are working perfectly for the macros. I also deleted Module1.

This is clearly a rare and strange bug in Word 2007. It was probably caused (somehow) by taking my Normal.dotm from my old installation of Windows XP and copying it to the new Windows 7 and Word 2007.

share|improve this answer

I do not have Word 2007 to hand. On my version of Word, you:

  • Select Tools then Options then Security then Macro Security then Security Level.
  • Set Security level to Medium.
  • Click OK twice.

With Word 2007, the start point may be slightly different but the principle will be the same.

Good luck.

share|improve this answer
    
In Word 2007 it the macro security settings are more detailed. As mentioned in my post, my settings are: "Disable all macros except digitally signed macros". The macros run (just not from a shortcut key). Thanks. –  Dean Hill Mar 5 '12 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.