Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a PC with specs:

  • XP SP3,
  • Intel Pentium 4 3 GHz,
  • Asus P5GC-MX motherbord,
  • 2 Ghz DDR2 memory (1 GHz x 2).

I used to use hibernate to shut down my PC because it saves time opening many applications and the data that I use frequently. That worked well.

But, a few days later, my PC does not power off after hibernate. I can see the hibernate progress bar run to completion, but after that my pc is idle and the power is still "alive".

This may sound strange but I suspect my new android smartphone. I bought it recently. I often connect the smartphone to the pc using a usb cable to exchange data and applications. Since the use of the android phone, my pc can not hibernate successfully if

  • I connected the smartphone though the usb
  • Turned off the data connection
  • Unplugged the cable

But, if I haven't connected my pc to the smartphone since the pc was turned on, hibernate can run successfully.

Edit

I forgot to say that I installed bluetooth software a couple of days ago, but the software didn't work so I uninstalled it. This morning I ran ccleaner and it seems solve the hibernate problem.

EDIT AGAIN

Sorry, It happened again. here what i did. I opened some weight applications like eclipse with android emulator and firefox with many tabs. i used process hacker to monitor cpu usage. when the applications running that hit 60%-70% cpu usage but i can use the application without problem. if i closed the emulator, the cpu usage is low. i did close the emulator before hibernate my pc. but like i told before, my pc was idle and the power was still alive though the hibernate process was completed.

For more informations. i found some errors "The driver detected a controller error on \Device\Harddisk0\D" in the event viewer. D is my DVD SATA drive. i dont know if the problems related.

share|improve this question
1  
You can post that Edit as an Answer and then accept it in a day when it allows you to. –  music2myear Mar 6 '12 at 15:26

1 Answer 1

Based on your updates the issue was (like it almost always is with Sleep, Hibernate, and other power state issues) a driver problem.

Each driver installed on your computer must support the desired power state. Some drivers are poorly written (this can be more common with cheaper peripherals, but can happen with nice expensive bits too) and either the driver does not accept a certain power state, or the driver specifies a power state the device itself does not support. Either way, when you try to go to that power state (sleep, hibernate, etc) you'll experience any of several issues, including your system just not doing what you told it to do.

The solution is usually first to look for updated drivers online for any recent add-ons, install any and all important windows updates, as well as check for updated mainboard drivers. If that doesn't work, try completely uninstalling the drivers for the new device (like you did using CCleaner, driver uninstallers are notoriously un-thorough). If either of these fixes the issue, it was the drivers or the device, like you found.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.