Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to configure the directory SQL Developer uses to save SQL scripts?

When I do ... File, New, SQL File ... the directory is always set to the \AppData\Roaming\ for my user.

I'd like to set the default to a directory in my dev source code tree.

share|improve this question
If it is hardcoded, you should think about just dropping a symlink to your desired directory in Appdata\roaming. – surfasb Mar 6 '12 at 14:57
Checked the registry and can't find any setting – SteveC Mar 8 '12 at 16:15

When you go to save your sql file you can change where the save defaults to. Change it in Tools>Preferences>Database>Worksheet Parameters. You can browse to a new location under "Select default path to look for scripts"

Can also change the Export Data so that it defaults to somewhere else. Go to Tools>Preferences>Database>Export and Browse to the location you want to export to for "Directory"

This used to annoy me bad before I changed it. Now all my saves and exports default to a folder I actually use.

share|improve this answer
up vote 3 down vote accepted

Found it ...

In the Choose Directory dialog, the left hand side has a number of commonly used short cuts, e.g. Desktop, Documents, but you can also have your own directories in there

share|improve this answer

There is a post about this in OTN, and AlexAnd's solution opens the specified folder when I do File => Open.

The post is @

AlexAnd is saying that locate "\sqldeveloper\sqldeveloper\bin\sqldeveloper.conf" and simply add "AddVMOption -Dide.user.dir=" (where " is the full folder path that you like to use) to that file.

The disadvantage of this solution is that it will also move your settings folders to the specified folder (for me it was about 34MB), I use drop box to keep my queries so that is a wasted space.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .