Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an older computer that has an Asus CD/DVD Reader/Writer. The problem is that the tray is stuck open: it does close normally, but the motor keeps going after the tray is closed, and after a few seconds it pushes the tray back out.

The tray also has some difficulty moving, so usually it needs to be pushed. So is this fixable, how can I fix it?

share|improve this question
1  
Did the tray get bumped badly when it was out? I would first suspect that it gear slipped /\/\/\/\/\/\ –  Psycogeek Mar 6 '12 at 15:27
1  
If you have nothing to lose, and you know it got jammed in, jam it back out till you hear a click, which will be the gear breaking into pieces :-) –  Psycogeek Mar 6 '12 at 15:50
add comment

3 Answers

Considering the cost of a DVD writer? Replace it, take apart the old one and find out.

I do note it sounds like it isn't closing all the way, something is jammed and its trying to eject to remove what it percieves to be a stuck disk. Unfortunately, the only way to really find out is to take it apart since this is usually a mechanical issue. Look for broken or out of place gears and so on.

I had a similar thing happen when i accidentally kneed an open tray on a DVD drive but i ended up junking it rather than fixing it

share|improve this answer
3  
This, just replace the damned thing. A good DVD burner can be had for less than the cost of a good DVD. –  Shinrai Mar 6 '12 at 15:49
2  
No way, that's just wasting money :D I took it apart, and the problem with the tray mechanism: dust combined with the lubricant, making it ineffective. So I cleaned that lubricant, and now it works like brand new. –  Tibi Mar 7 '12 at 17:40
add comment

I had the same problem and removed the drive.

After removing the case, I found the laser transport was rising too early and the tray was hitting it. Do not try to force or you may damage the transport. I found that with a small flat screwdriver you can bend the release tabs at the back of the tray.

Make sure the gears are backed up and the slide bar that initiates the transport to rise is all the way to the left. Carefully re-insert the tray (it may take a few tries to achieve satisfactory results), and assemble the case. Install the drive back into the computer and test. Mine worked like new.

share|improve this answer
    
Turns out the drive was failing to raise the transport, the belt between the motor and the tray mechanism was slipping. Took it to a computer repair shop, and they fixed that belt for around $3, and now it is working –  Tibi Mar 2 '13 at 10:37
add comment

I had this problem: I turned the CPU upside down and I was able to get it closed after a couple tries. At least for me, I think something had fallen/shifted and was jamming the door closing mechanism.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.