Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Windows 8 on a PC behind a proxy. I had setup the proxy in Internet options and IE works well, but Modern UI (aka Metro) apps instead seem to not be able to exit. Is there any workaround?

share|improve this question
    
What is under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\WinHttpSettings? Metro style apps do not use the WinInet proxy in IE options –  Sheng Jiang 蒋晟 Mar 6 '12 at 18:56

4 Answers 4

up vote 11 down vote accepted

I searched for a solution all around internet and I finally find a way how to do it:

Open command prompt as admin and write:

netsh
winhttp
import proxy source=ie

Now the Microsoft Store works, some other services like Music not, but that is a problem of regional filtering (I am located in Italy).

Hope it helps, unfortunately I do not remember the source of this script.

Side note: I upgraded to Windows 8.1 and it seems they have fixed the proxy glitch. Now it is sufficient to change the global proxy settings (Internet Properties) and Metro apps use that settings accordingly.

share|improve this answer
    
If you used this and can't get windows update to work, it is because your proxy settings doesn't sync with ie, it was just imported, so you probably still have your proxy settings in there, to reset your proxy follow the same steps but replace import .... with reset proxy –  Shereef Marzouk Feb 8 '13 at 6:07
    
@pratnala's recommendation below to enable loopback is important –  Alexei Danchenkov May 15 '13 at 20:57

Please visit my blog for the solution. I have made Video Tutorial for this. http://deepeshsingh93.wordpress.com/2013/08/06/how-to-run-windows-8-app-store-under-college-proxy-server/

share|improve this answer
3  

I had the same problem in our university where we are behind a squid proxy with basic authentication. To solve this problem with Modern UI apps, I installed CC Proxy. Configure CC Proxy to a cascading set up. Then, you need to put your IP address with port 808 in internet options and run the netsh command. You also need to enable loopback for the Modern Apps to be able to use a local proxy server as they by default cannot route network traffic to a local proxy server.

This should work for most configurations.

share|improve this answer

I have listed a suggestion from Andrew Willows (MSFT) as a possible solution.

  1. Open "Local Group Policy Editor"
  2. Navigate to "Computer Configuration - Administrative Templates - Network Isolation"
  3. Open "Internet Proxy Servers for Metro Style Apps" and set the value to your proxy server address like 172.16.0.1:8080.

We shouldn't need to amend other settings in here for now.

I would encourage a restart here, although this shouldn't be necessary but during testing it may help clear down any cached data that could interfere. If you still have issues with proxy settings, please post in TechNet ITPRO forum.

share|improve this answer
    
It states "not fot desktop apps". Apps like weather are still not working even after doing it. I think the problem is with proxy authentication(as the local sites that do not require authentication run in the metro IE). I have installed squid that works well on the regular desktop of win 8 but not on these metro apps. –  user151353 Aug 9 '12 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.