Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

New lenovo x220 laptop with Windows 7 Pro with the below specs. I want to backup the disk to my server but I need to know the W7 fs, what is it?

$ sudo mount -t ntfs /dev/sdb Windows/
NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
$ sudo mount -t ntf /dev/sdb Windows/
mount: unknown filesystem type 'ntf'
$ sudo mount -t nts /dev/sdb Windows/
mount: unknown filesystem type 'nts'

$ dmesg|tail
[   25.928832] sdb: p2 size 4779917312 extends beyond EOD, truncated
[   25.928867] sdb: p3 start 4804509696 is beyond EOD, truncated
[   25.929882] sd 6:0:0:0: [sdb] 78142806 4096-byte logical blocks: (320 GB/298 GiB)
[   25.931382] sd 6:0:0:0: [sdb] No Caching mode page present
[   25.931387] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[   25.931392] sd 6:0:0:0: [sdb] Attached SCSI disk
[   27.960028] wlan0: no IPv6 routers present
[  174.655199] EXT3-fs (sdb): error: can't find ext3 filesystem on dev sdb.
[  174.657319] EXT2-fs (sdb): error: can't find an ext2 filesystem on dev sdb.
[  174.660818] EXT4-fs (sdb): VFS: Can't find ext4 filesystem

Perhaps related

  1. http://unix.stackexchange.com/questions/11028/backup-whole-hard-disk-linux

  2. USB-SATA adapter -suggestion to connect the new HDD to my *ix laptop, http://superuser.com/a/387134/114739

  3. I am using these SATA to HDD 2.5" Adapters here and here, bought two pieces but both seems to work at least automounting works with them in Ubuntu and Windows.

To Luke's comment

$ sudo fdisk -l

Disk /dev/sda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders, total 117231408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000da58e

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   113055743    56526848   83  Linux
/dev/sda2       113057790   117229567     2085889    5  Extended
/dev/sda5       113057792   117229567     2085888   82  Linux swap / Solaris
Note: sector size is 4096 (not 512)

Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 4864 cylinders, total 78142806 sectors
Units = sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x181d6d22

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048     3074047    12288000    7  HPFS/NTFS/exFAT
/dev/sdb2         3074048   600563711  2389958656    7  HPFS/NTFS/exFAT
/dev/sdb3       600563712   625139711    98304000    7  HPFS/NTFS/exFAT

Err to Lamar's comment

root@h:/# mount -t ntfs /dev/sdb2 /Windows/
NTFS signature is missing.
Failed to mount '/dev/sdb2': Invalid argument
The device '/dev/sdb2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
root@h:/# sudo mount -t ntfs /dev/sdb2 /Windows/
NTFS signature is missing.
Failed to mount '/dev/sdb2': Invalid argument
The device '/dev/sdb2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

$ sudo mount -t ntfs /dev/sdb2 /Windows
NTFS signature is missing.
Failed to mount '/dev/sdb2': Invalid argument
The device '/dev/sdb2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
share|improve this question
    
Isn't /dev/sdb the entire disk, instead of /dev/sdb1 or /dev/sdb2? What does fdisk -l output? –  Canadian Luke Mar 6 '12 at 19:15
    
Yeah, the filesystem of the primary installation should be NTFS. –  Shinrai Mar 6 '12 at 19:16
    
No, it hasn't changed. It will be changing with Windows 8 but ReFS is supposed to look exactly like NTFS to any API that's accessing it so everything that already reads NTFS should continue to read NTFS (although some low-level stuff might not work properly, obviously) –  Shinrai Mar 6 '12 at 19:22
    
sudo mount -t ntfs /dev/sdb2 /windows slashes are important –  Lamar B Mar 6 '12 at 19:25
    
In the question you never have a partition number after the drive letter. And in your comment you don't have the leading slash on windows. Both of these could be causing errors or a mistype could have easily occurred. –  Lamar B Mar 6 '12 at 19:33
show 10 more comments

3 Answers

You can clone the whole drive to an image file with dd, you can even compress it to save space:

sudo dd if=/dev/sdb2 | bzip2 >~/old-disk.img.bz2

If you have pv, you can even get a progress bar:

sudo pv /dev/sdb2 | bzip2 >~/old-disk.img.bz2
share|improve this answer
    
+1 for the clever idea to use compression, hopefully saves time.. –  user114739 Mar 6 '12 at 20:46
    
It won't save time, it'll save storage! –  deed02392 Mar 7 '12 at 9:07
    
...I think I need to plug in Rsync somewhere, it takes 30hours -- I have disk that is 60GB used but apparently about 300Gb free space (not sur but takes more than expected), researching the way to user rsync. –  user114739 Mar 15 '12 at 15:02
add comment

You want to use NTFS-3G, note 3G.

This should do the trick:

$ mount -t ntfs-3g /dev/sdb2 /mnt/point

I regularly use this to mount my external hard drive with a Server 2008 R2 virtual hard disk on it under Debian Squeeze.

share|improve this answer
    
root@xfz:/# mount -t ntfs-3g /dev/sdb2 /Windows/ NTFS signature is missing. Failed to mount '/dev/sdb2': Invalid argument The device '/dev/sdb2' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around? -- well the same err. Even same err with sdb1, sdb --. –  user114739 Mar 6 '12 at 19:51
    
Try $ ntfs-3g /dev/sdb2 /mount_point ? –  deed02392 Mar 6 '12 at 19:54
    
root@xfz:/# ntfs-3g /dev/sdb2 /Windows/ NTFS signature is missing. Failed to mount '/dev/sdb2': Invalid argument The device '/dev/sdb2' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?, I forget to mention -- I tried this one already -- the same err?! –  user114739 Mar 6 '12 at 20:07
add comment

The mount command should have /host and /Windows like this /host/Windows/. try it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.