Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My system is running Fedora 16 and I live in a campus where we use LAN to connect to the Internet. And for this, we use an http proxy with authentication (username & password).

I tried putting the proxyaddress:port in the Network Proxy settings after going to the Network Settings window. However, it never asked for an authentication and the programs that use the internet are unable connect, except for Firefox because it asks for authentication.

Also, I could get Yum to work by manually editing yum.conf. I even tried using http://username:password@proxy:port like in the Yum configuration but it has not helped.

Is there any solution to this problem?

share|improve this question
add comment

2 Answers

Its a 2 step process.

When you run a yum command it goes directly to the internet UNLESS you have set a proxy in its configuration file. When yum tries to go through the proxy the proxy queries the computer for the authorization, by talking to the shell, if it gets correct details it then allows the yum process to proceed.

  • Tell yum where the proxy is in /etc/yum.conf

http_proxy=http://172.17.30.20:80/

  • Put your own authentication details in your system's /root/.bashrc

    myusername="whatever_it_is"
    mypassword="whatever_it_is"
    ourproxy="http://172.17.30.20:80/"   <--use your actual id
    export http_proxy=$myusername:$mypassword@$ourproxy
    
share|improve this answer
    
I submitted an edit for this answer, but the code blocks don't seem to want to be working. I submitted a bug report here. –  Qix Feb 7 '13 at 6:03
add comment

Network Proxy Settings dialog works only for Gnome applications. In order to use proxy in console (even if you're using Gnome terminal to run console commands) you will need to export http_proxy and https_proxy variables. Adding export http_proxy=http://username:password@proxy:port line into your /etc/environment should help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.