Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Unfortunately my mom did something that I don't know and Linux is in command-line mode. What is the key for exiting from the shell and going to the desktop?

I tried

  • Alt + F2
  • Alt + F6
  • Ctrl + Alt + F2
  • Ctrl + Alt + Delete
  • exit

No one worked for me. It goes to the black shell and tells me enter login and root password. When I enter it, it shows me repair file system in red color. Alt + F2 shows me a blank black page and Alt + F1 will return back to this shell.

My version is openSUSE 11.1.

share|improve this question
try Alt + F1 ___ – inf Mar 7 '12 at 14:30
it did nothing for me – Nickool Mar 7 '12 at 14:33
up vote 4 down vote accepted

"shows me repair file system in red color"

This is the key: the filesystem is corrupted, probably due to an unclean shutdown. It needs to be repaired. Try entering the root password, which should give you a '#' prompt. Type:

fsck -A -y

That will take a while and print out something about what it's fixing. Once that has completed, type "exit". You may need to restart the system again.

share|improve this answer
yes It is tell me fixed fixed fixed and It has questions which itself tells yes yes yes hope It will help thanks – Nickool Mar 7 '12 at 14:58
I love you so much!!!! thanks thanks what can I do for you!!!! thank you!!!!!! – Nickool Mar 7 '12 at 14:59
Take it it's working then :) If you could edit the subject line of your original question to something like "How to recover linux from 'repair file system' error" that would be great. Also, now you've got your files back BACK THEM UP SOMEWHERE. – pjc50 Mar 7 '12 at 17:26
:D Yes I should do it! ok I change the subject for users:) – Nickool Mar 7 '12 at 19:20

Ctrl + Alt + F7 should return you to the GUI if it is still running. If not, try startx.

share|improve this answer
it showed me nothing – Nickool Mar 7 '12 at 14:35

Depending on the distribution, the X server may have taken over the slot usually occupied by tty1 or tty7. On Fedora, ctrl+alt+F1 takes me back to the X server; ctrl+alt+F7 used to work on Ubuntu.

Failing that, X may have died - in which case you have two choices:

  • Try startx - you'll need to be logged in and with the appropriate scripts configured; not all distributions have this.
  • Restart init. To do this: log in, type:

    $ sudo -i
    # init 3
    # init 5

    You may need to re-login between the two inits, depending on your distribution. init 5 means "start multi-user graphical mode" and should boot you up into X. init 3 will likely kill any running applications you have, by the way.

share|improve this answer
startx tells me fatal server error read only file system /root/.serverauth.1505 – Nickool Mar 7 '12 at 14:39
You'll need to be root then; try sudo -i which should log you in to the interactive root prompt, then startx. – user26996 Mar 7 '12 at 14:41
It tells me many errors xinit:no such process(errno 3):Server error errors in locking authorithy lobloblob – Nickool Mar 7 '12 at 14:44
@nik hmmm. Have you tried the ctrl+alt+FX approach? Xs can be from 1-8 I think. – user26996 Mar 7 '12 at 14:46
yes I tried them I wanna Die! Ireally need my desktop! I can't again install suse because I have many documents spread everywhere – Nickool Mar 7 '12 at 14:48

The CLI (Command Line Interface) is not a "window" or program in Linux like it is in recent versions of Windows.

So you are not trying to Exit the CLI, you are trying to Start the Graphical User Interface (GUI).

First off: Have you restarted the computer? And what version or Distro are you using?

Update 1:

Instructions for starting KDE from CLI in opensuse are to run the command:




Update 2:


The first thing to do is to make sure that KDE will start up from the command line. On SUSE, KDE is installed into the /opt/kde3 folder and all the commands can be found in the bin sub folder. This directory will probably not be in your path as KDE set this in its start up routine.

Your path is a list of folders where Linux looks for commands (Tools, Utilities and Applications) to run.

You can find out your path with the command line:

$ echo $PATH

The command to start the KDE GUI (Graphical User Interface) is a shell script called "startkde".

The script checks to see that everything is cool for it to run correctly, and adds its command folder to your path.

It does lots of other checks and sets up its graphics, fonts, and user preferences. Then it starts the X server and KDE.

Running the command from the command line will let you see any error messages in case it does not start properly. What you do about these is beyond the scope of this answer as there could be many reasons why it didn't work. Hopefully the error messages will be self explanatory.

You can run this command in two ways. Either by giving the full path name thus:

$ /opt/kde3/bin/startkde

or by:

$ cd /opt/kde3/bin

$ ./startkde

If none of those solutions work, I'd recommend running a repair or reinstall of KDE.

Update 3:

Try using xwmconfig to (re)set your X Window Manager to KDE

share|improve this answer
yes,opensuse 11.1 KDE – Nickool Mar 7 '12 at 14:32
And what GUI were you using: Gnome, KDE, something else? – music2myear Mar 7 '12 at 14:33
It is KDE music2myear – Nickool Mar 7 '12 at 14:37
It tells me $DISPLAY is not set or cannot connect to the xserver – Nickool Mar 7 '12 at 14:45
Then you're beyond my depth in Linux. It sounds like your graphics driver is messed up or the xserver (the window manager) is not running. Googling that error message gives some promising results from others who've had the same issue. It appears you'll need to try an alternative way of starting KDM. – music2myear Mar 7 '12 at 14:48

Try to restart your computer:

sudo shutdown -r now
share|improve this answer
It just restarted me in again that mode – Nickool Mar 7 '12 at 14:37
may be you can re-install the kde-desktop zypper install -t pattern kde4 kde4_basis – thehilmisu Mar 7 '12 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .