Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

unfortunately my mom did something that I don't know and the linux is in command line mode what is the key for exiting from shell and going to desktop? I tried

alt+f2
alt+f6
ctrl+alt+f2
ctrl+alt+delete
exit

no one worked for me It goes to the black shell and tell me enter login root password when I enter it it shows me repair file system in red color alt+f2 shows me blank black page and alt+f1 will return back to this shell my version is opensuse 11.1

share|improve this question
    
try Alt + F1 ___ –  bamboon Mar 7 '12 at 14:30
    
it did nothing for me –  Nickparsa Mar 7 '12 at 14:33

5 Answers 5

up vote 5 down vote accepted

"shows me repair file system in red color"

This is the key: the filesystem is corrupted, probably due to an unclean shutdown. It needs to be repaired. Try entering the root password, which should give you a '#' prompt. Type:

fsck -A -y

That will take a while and print out something about what it's fixing. Once that has completed, type "exit". You may need to restart the system again.

share|improve this answer
    
yes It is tell me fixed fixed fixed and It has questions which itself tells yes yes yes hope It will help thanks –  Nickparsa Mar 7 '12 at 14:58
    
I love you so much!!!! thanks thanks what can I do for you!!!! thank you!!!!!! –  Nickparsa Mar 7 '12 at 14:59
    
Take it it's working then :) If you could edit the subject line of your original question to something like "How to recover linux from 'repair file system' error" that would be great. Also, now you've got your files back BACK THEM UP SOMEWHERE. –  pjc50 Mar 7 '12 at 17:26
    
:D Yes I should do it! ok I change the subject for users:) –  Nickparsa Mar 7 '12 at 19:20

ctrl-alt-F7 should return you to the GUI if it is still running if not try startx

share|improve this answer
    
it showed me nothing –  Nickparsa Mar 7 '12 at 14:35

did you try the restart your computer

try this

sudo shutdown -r now
share|improve this answer
    
It just restarted me in again that mode –  Nickparsa Mar 7 '12 at 14:37
    
may be you can re-install the kde-desktop zypper install -t pattern kde4 kde4_basis en.opensuse.org/SDB:KDE_install –  thehilmisu Mar 7 '12 at 14:46

Depending on the distribution, the X server may have taken over the slot usually occupied by tty1 or tty7. On Fedora, ctrl+alt+F1 takes me back to the X server; ctrl+alt+F7 used to work on Ubuntu.

Failing that, X may have died - in which case you have two choices:

  • Try startx - you'll need to be logged in and with the appropriate scripts configured; not all distributions have this.
  • Restart init. To do this: log in, type:

    $ sudo -i
    # init 3
    # init 5
    

    You may need to re-login between the two inits, depending on your distribution. init 5 means "start multi-user graphical mode" and should boot you up into X. init 3 will likely kill any running applications you have, by the way.

share|improve this answer
    
startx tells me fatal server error read only file system /root/.serverauth.1505 –  Nickparsa Mar 7 '12 at 14:39
    
You'll need to be root then; try sudo -i which should log you in to the interactive root prompt, then startx. –  Ninefingers Mar 7 '12 at 14:41
    
It tells me many errors xinit:no such process(errno 3):Server error errors in locking authorithy lobloblob –  Nickparsa Mar 7 '12 at 14:44
    
@nik hmmm. Have you tried the ctrl+alt+FX approach? Xs can be from 1-8 I think. –  Ninefingers Mar 7 '12 at 14:46
    
yes I tried them I wanna Die! Ireally need my desktop! I can't again install suse because I have many documents spread everywhere –  Nickparsa Mar 7 '12 at 14:48

The CLI (Command Line Interface) is not a "window" or program in Linux like it is in recent versions of Windows.

So you are not trying to Exit the CLI, you are trying to Start the Graphical User Interface (GUI).

First off: Have you restarted the computer? And what version or Distro are you using?

Update 1:

Instructions for starting KDE from CLI in opensuse are to run the command:

startx

or

startkde

Update 2:

From http://www.novell.com/coolsolutions/feature/11550.html

The first thing to do is to make sure that KDE will start up from the command line. On SUSE, KDE is installed into the /opt/kde3 folder and all the commands can be found in the bin sub folder. This directory will probably not be in your path as KDE set this in its start up routine.

Your path is a list of folders where Linux looks for commands (Tools, Utilities and Applications) to run.

You can find out your path with the command line:

$ echo $PATH

The command to start the KDE GUI (Graphical User Interface) is a shell script called "startkde".

The script checks to see that everything is cool for it to run correctly, and adds its command folder to your path.

It does lots of other checks and sets up its graphics, fonts, and user preferences. Then it starts the X server and KDE.

Running the command from the command line will let you see any error messages in case it does not start properly. What you do about these is beyond the scope of this answer as there could be many reasons why it didn't work. Hopefully the error messages will be self explanatory.

You can run this command in two ways. Either by giving the full path name thus:

$ /opt/kde3/bin/startkde

or by:

$ cd /opt/kde3/bin

$ ./startkde

If none of those solutions work, I'd recommend running a repair or reinstall of KDE.

Update 3:

Try using xwmconfig to (re)set your X Window Manager to KDE

share|improve this answer
    
yes,opensuse 11.1 KDE –  Nickparsa Mar 7 '12 at 14:32
    
And what GUI were you using: Gnome, KDE, something else? –  music2myear Mar 7 '12 at 14:33
    
It is KDE music2myear –  Nickparsa Mar 7 '12 at 14:37
    
It tells me $DISPLAY is not set or cannot connect to the xserver –  Nickparsa Mar 7 '12 at 14:45
    
Then you're beyond my depth in Linux. It sounds like your graphics driver is messed up or the xserver (the window manager) is not running. Googling that error message gives some promising results from others who've had the same issue. It appears you'll need to try an alternative way of starting KDM. –  music2myear Mar 7 '12 at 14:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.