Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to use remotely some graphical application in a linux machine. For very basic applications, I just connect remotely from my OS X Lion using

ssh -X machine:

and then

./gedit &

and it works. But for more complex graphical applications, they hang up constantly and I get the error:

Xlib:  extension "NV-GLX" missing on display "localhost:11.0".

I wonder how could I circumvent this. Somebody recommended vncserver and vncclient, while others X -query

share|improve this question
Hello. NV-GLX is a part of NVidia's binary driver package. There have been some problems with the latest version of Nvidia's driver (295.10). It causes hangs and segfaults in some applications. Could you switch to Nouveau driver and see if the error persists? P.S. Did you try running the same apps on the Linux box? Do you get the same errors? – Kaurin Mar 7 '12 at 17:00
in a linux ubuntu box i got the same problem (well, it was in the same machine under a virtual machine) – flow Mar 7 '12 at 17:47
how could I switch to Nouveau driver? Would I kill OSX Lion? – flow Mar 7 '12 at 18:08
Let me see if I understand you correctly: You have Physical machine (MAC) with MAC OS X Lion and a Physical machine with Ubuntu. Is this correct? – Kaurin Mar 7 '12 at 18:17
No. I have a macbook pro running os x lion. Underneath a virtualmachine running ubuntu. So it us the same problem since in this case the VM accesses the graphics with the same problematic – flow Mar 7 '12 at 22:12
up vote 2 down vote accepted

I would say that the capability detection of your X application breaks down somewhere - it wants to use GL rendering, but the X server will have none of it. Can you please try setting LIBGL_ALWAYS_SOFTWARE=1 in the environment? That should force your application to not use hardware rendering for OpenGL.

Have a look at this one here: Force software based opengl rendering

share|improve this answer
I tried setting the flag, but get the same error, will have a look at the link – flow Mar 8 '12 at 10:30
not all apps honor the env. Does it maybe have command line switches to disable OpenGL acceleration? – Florenz Kley Mar 8 '12 at 10:37
unfortunately not, as far as I can see. I also tried from a linux machine, installing the GL software driver but same error, seems to be application scpefici error – flow Mar 8 '12 at 10:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.