Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I took a plunge and installed Windows 8 Consumer Preview on my main home PC. So far so good, but there is one annoyance - the system "locks" the computer after a period of inactivity causing me to re-enter my password.

I really would like to avoid this, but have no idea how. I already tried the power settings (no pass on wake up) and the screen saver settings with no luck. Is this some sort of bug, or am I missing something?

P.S. In this case I favor convenience over security.

share|improve this question
    
Set the period of time before the lockscreen appears. Use the same procedure you would use for Windows 7. –  Ramhound Mar 7 '12 at 19:02
    
How? I tried settings on the props page for Screen Saver and Power Options. Is there a different place? –  Filip Frącz Mar 7 '12 at 19:20

6 Answers 6

Check under power options. Setting --> control panel --> System and Security --> Power Options--> Password protection on wakeup

share|improve this answer
3  
If it isn't obvious, click the "Change options currently unavailable" if you want to change Pass protection. –  Valoric Mar 9 '12 at 1:12

I think this is a bug, at least on my installation If i change the screen saver timeout from the default 5 mins to anything else then click OK or Apply and come back to Screen saver settings it has reverted back to 5 mins

share|improve this answer
    
Saw the same behavior but I don't think we're talking about the screensaver here. It's more about the lock screen of Win8 –  Jacques Nov 28 '12 at 12:35

You can get rid of the lock screen (before the login prompt) by means of a policy change. Start gpedit.msc, then go to Computer Configuration -> Administrative Templates -> Control Panel -> Personalization and in the left pane double-click the setting Do not display the lock screen and set it to Enabled.

Copied from another answer by me here.

share|improve this answer
    
gpedit.msc does not exist for me, other suggestions? –  PsychoDad Jul 14 '13 at 3:35
    
@PsychoDad: see the other answer in that case. –  0xC0000022L Aug 10 '13 at 12:04
    
@PsychoDad gpedit.msc needs Windows Pro resp. Windows Enterprise. –  Peter Nov 26 at 18:19

Type "EAS" in the Metro Start Screen and click Settings on the right side. From there you can reset the EAS Policies. This will help if you have connected a mail account which enforces some security policies.

If you have a non-english Windows installed try the following (instead of typing EAS): Win+X and open Control panel > Control Panel > User Accounts > Reset Security Policies.

After this, you should be able to disable the requirement for password under PC Settings → User.

share|improve this answer
3  
You don't need to disable the password. The user just doesn't want the Start Screen to appear after a period of inactivity. –  Ramhound Sep 5 '12 at 10:55

Control Panel\Hardware and Sound\Power Options\System Settings click "change settings that are currently unavailable" and than choose at password protection on wakeup "don't require a password"

share|improve this answer

(Posting this answer for searchability)

The answer on this page (http://www.askvg.com/how-to-disable-lock-screen-in-windows-8/) worked for others in my organization, but not for me. The solution there was:

METHOD 1: Using Group Policy Editor (gpedit.msc)

  1. Press "WIN+R" key combination to launch RUN dialog box then type gpedit.msc and press Enter. > It'll open Group Policy Editor.
  2. Now go to: Computer Configuration -> Administrative Templates -> Control Panel -> Personalization
  3. double-click on "Do not display the lock screen" option and set its value to "Enabled".

METHOD 2: Using Registry Editor (regedit)

  1. Set via regedit: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Personalization
  2. create a new DWORD NoLockScreen and set its value to 1

NB: I'm running OSX, and then a Windows 8 VM with Parallels. @teeney-weeny's solution worked for me since the Parallels profile had some overrides.

Admittedly, my current environment has a cumulative solution (method 1 + method 2 + @teeney-weeny's solution).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.