Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying the install Win8 in a VHD using the Hanselman Guide

All went well until the PC rebooted and Windows shows me this error:

Your PC needs to be repaired

The application or operating system couldn't be loaded because
a required file is missing or contains errors.

File:\windows\system32\winload.exe
Error code: 0xc000000e

enter image description here

Ideas?

share|improve this question
1  
Perhaps your install source or target disk is corrupted, have you check them, and/or tried the install more than once? Is the VHD located on an internal drive? –  Ƭᴇcʜιᴇ007 Mar 7 '12 at 22:49
    
Also, have you tried repairing the boot records/sector? (Bootrec.exe) –  Ƭᴇcʜιᴇ007 Mar 7 '12 at 22:56
    
Yes, tried two times, same result. VHD in internal drive –  Eduardo Molteni Mar 7 '12 at 23:37
    
Haven't tried with Bootrec. How? –  Eduardo Molteni Mar 7 '12 at 23:38
    
Tried Bootrec /fixMbr and /fixBoot. Both ok. But /rebuildbcd says: total windows installations: 0. Is that a bad thing? –  Eduardo Molteni Mar 8 '12 at 12:23

3 Answers 3

I had this exact same problem, and I fixed it by moving the VHD to my C drive.

share|improve this answer
    
Too bad, because my C: is a SSD with almost no free space. –  Eduardo Molteni Apr 9 '12 at 13:40

I'd suggest you first compare the hash on your ISO.

MD5: cda63e335fb9af5354c63441f5aa5169 SHA1: 1288519c5035bcac83cbfa23a33038ccf5522749

Worse comes to worse, try a reinstall. Personally, I've run the Dev preview off VHDs. Haven't had time to try this one.

share|improve this answer
    
The hash are ok –  Eduardo Molteni Mar 8 '12 at 12:24

Error code 0xc000000e is STATUS_NO_SUCH_DEVICE, which is a bit sad. \system32\winload.exe is the first file loaded off the disk (it runs the preboot environement before \system\ntoskrnl.exe is loaded which is the first bit that anyone would recognise as Windows), so this looks like something in the filesystem driver is objecting to how your virtual machine is representing your virtual disk to the OS (i.e Windows doesn't like the virtual hard disk controller).

Has Windows 8 ever successfully booted up on that Virtual machine before? If not - it may be that the particular virtual machine software you are using isn't supported by the Windows 8 Preview, in which case your best bet is to go and use a different VM software.

If you have booted up on that VM before, this looks like something has gone badly wrong and you might need to reinstall the OS.

share|improve this answer
    
Never successfully booted from the VHD before. It's like the hardware cant find the VHD or the VHD does not "stick" in the boot configuration (or something) –  Eduardo Molteni Mar 8 '12 at 12:13
    
In which case it's most likely that this is just Windows8 not being fully supported by your virtual machine software. Windows8 is best run on Microsoft's Hypervisor VM (which is what they use to test internally and the only one that Microsoft guarantees will work), otherwise VMware workstation are probably your best bet. –  SecurityMatt Mar 8 '12 at 18:31
    
I'm not running any VM software, I'm only virtualizing the hard disk. –  Eduardo Molteni Mar 8 '12 at 19:05
    
So you're doing a boot-from-VHD from a Windows8 install on bare metal? In which case this is a bug in Win8, file a bug with Microsoft. –  SecurityMatt Mar 8 '12 at 19:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.