Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I open these applications in my desktop computer:

  • Visual Studio 2010 Professional
  • IBM Lotus Notes
  • Google Chrome

And when it is idle for an hour and I restore the windows, the user interface responds very slowly. My computer auto-lock itself after being idle for 5 minutes. I also minimize the applications using a docklet (RocketDock).

Why is it slowing down and how can I prevent it from slowing?

My OS is Windows XP Professional SP3, Pentum(R) Dual Core @ 2.80 GHz, 1.99 GB of RAM.

Please help. Thanks in advance.

share|improve this question
    
What's with the downvote? –  John Isaiah Carmona Mar 8 '12 at 9:05
add comment

1 Answer

up vote 0 down vote accepted

Please check your RAM usage, as windows is probably paging (Copying to disk) these memory intensive programs that are idle.

see this post: How to reduce disk thrashing (paging)?

share|improve this answer
    
As well, in WinXP, default behaviour is to always keep physical memory as empty as possible. Hence why disabling paging resolves this issue on XP, but doesn't really do much on Vista/7. –  EKW Mar 8 '12 at 7:08
    
@EKW Should I disable my paging? How can I disable it? Please help. –  John Isaiah Carmona Mar 8 '12 at 9:03
1  
@JohnIsaiahCarmona With 2gb of RAM, I would definitely not recommend disabling paging. GKoe's answer is a good one - check your memory usage in Task Manager, and upgrade it if your maximum Commit size is greater than your physical memory. –  EKW Mar 8 '12 at 15:29
    
@EKW Thanks. I'll try it. –  John Isaiah Carmona Mar 9 '12 at 1:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.