Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Permissions are fine (inherited) and checking effective permissions everything is AOK.

enter image description here

As you can see i can make a file in the docs folder but not the pdf_docs subfolder.

enter image description here

The folder has a lot of files and is quite large- i wonder if i've reached a limit? I couldn't find anything on google.

Size: 51.0 GB (54,819,804,885 bytes)
Size on disk: 52.0 GB (55,925,719,040)
Contains 554,697 Files

EDIT I've just checked and i can delete files... and for every file i delete i appear to be able to create a new one. This definitely points toward a limit in terms of number of files?

enter image description here

share|improve this question
7  
Time for a chkdsk –  ta.speot.is Mar 8 '12 at 11:03
4  
It seems to be a network drive. You should check the disk on which the actual data is located, not the properties of your locally mapped drive. –  Oliver Salzburg Mar 8 '12 at 11:40
2  
@OliverSalzburg you're right, I'd have a look at quotas first then permissions. –  Shadok Mar 8 '12 at 11:54
    
permissions, space and quota aok on the drive. as mentioned the parent folder is AOK and part of the same volume with inherited permissions. i have just added a screenshot that shows if i delete 1 file i can create 1 file... definitely seems to be linked to the number of files? –  Lee Tickett Mar 8 '12 at 13:46
    
does it behave differently if you are working on the server itself, rather than over a file share? –  Harry Johnston Mar 17 '12 at 22:38

4 Answers 4

It is likely that a quota has been set on the pdf_docs directory.

Directory quotas are configured using the File Server Resource Manager tool. You must be an administrator on the file server to use it.

share|improve this answer
    
there is no quota on the folder –  Lee Tickett Mar 16 '12 at 16:17

Assuming your permissions are indeed correct, and that the drive has sufficient storage space to create the file, I would check the number of characters in the full path to that folder. The maximum length for the path in Windows is 260 characters according to this answer on stackoverflow.

share|improve this answer
    
definitely not the problem as there are plenty of files in the folder and it has been working flawlessly up till now –  Lee Tickett Mar 8 '12 at 11:19
    
@LeeTickett So you did double-checked permissions, and actual storage space? –  Ƭᴇcʜιᴇ007 Mar 8 '12 at 13:17
    
yes- my screenshot even shows me able to create a file in the parent folder but not the subfolder –  Lee Tickett Mar 8 '12 at 13:31
    
If the file server is a linux or other unix-y machine running SAMBA, you could conceivably be hitting an inode limit on a poorly configured partition. That partition would have to be different for the sub-directory. –  Slartibartfast Mar 8 at 21:29

According to this image:

enter image description here

It looks like it's set to Read-Only. I think that any be your problem. If you deselect it probably will be fixed. If it isn't, it's something more serious.

share|improve this answer
    
In case you're wondering why anyone can change your answer (like I did), check this page. By the way, anyone (including you) can edit anybody's post but it will be reviewed by anyone with 2,000 rep or more (such as myself). –  Chipperyman Mar 24 at 4:34
    
If you read the whole question and look at the screenshots you'll see that deleting a file then allows me to add a new one- so that definitely isn't the issue. –  Lee Tickett Mar 24 at 8:17
    
The "read-only" flag prevents a directory from being deleted, but does not prevent files from being written to the directory. –  Harry Johnston May 5 at 0:38

In Windows a directory is implemented as an index file, and when an index file gets too fragmented it is not possible to add new entries.

To resolve the problem, defragment the index file as described here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.