Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't use distants port 22 anymore. This problem appeared "magically" when I booted today and tried to push some files on a remote git repo. I run on Ubuntu 11.10. I tried connecting to other servers I have access and I can't. However, no error message is displayed, the terminal just stay there, displaying :

ssh -v -v -v
OpenSSH_5.8p1 Debian-7ubuntu1, OpenSSL 1.0.0e 6 Sep 2011
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to [#.#.#.#] port 22.

I tried telnet, no more success :

telnet 22       
Trying #.#.#.#...

I tried deinstalling/reinstalling ssh, look at my iptables and route (default values), cleaned my ~/.ssh, nothing seemed to work. I really don't know what to do now, the only option I can see is complete reinstall. Do you have an (other) idea ?

Thanks in advance !

Update : I was finally able to connect on remote port 22 after shutting down the computer for thirty minutes. Yes, strange enough, as repeated reboots didn't do anything. I can only guess that @D_bye was right and the problem was on my organisation's wifi side. Thanks a lot for your time and suggestions !

share|improve this question
did you verify your connectivity? I mean can you ping the remote server? – Mallik Mar 8 '12 at 17:32
Yes, I can without problem. – FabPelletier Mar 8 '12 at 17:35
Check this solution... – Mallik Mar 8 '12 at 17:35
Doesn't seem to work, I'm still stuck ^^' – FabPelletier Mar 8 '12 at 17:55
up vote 0 down vote accepted

If both ssh and telnet give you the same symptoms (i.e., sitting there seemingly doing nothing), then it is in all probability not a problem with your ssh install.

Have you checked your router/firewall config? If you don't control the router/firewall, talk to the person that does. They may have either changed policy or fat-fingered a reconfig. I have seen similar problems with commodity switches, as well, so if you have a cheapo switch between your box and the 'Net, try restarting it.

share|improve this answer
I do control my firewall, but I didn't touch its config since I installed ubuntu, and it was a few months ago. I work from a public network and I had coworkers access the repo and the site I used for tests, without a glitch, so I guess it's safe to say it's not a swith either ? – FabPelletier Mar 8 '12 at 17:42
@FabPelletier - if others can connect to the server from the same network that you are on, then yes, it is safe to say it is not a switch on that network. It's also safe to say the server config is fine, and running correctly. Can you connect to other ssh servers on other machines from the same client computer? – D_Bye Mar 9 '12 at 10:51


  • Is sshd running?
  • Does your firewall permit ssh connections?
  • Are you running SELinux? (If so can you temporarily disable it to see if that's the problem?)
  • Check your sshd settings - do you allow root logins if you're trying to login as root? Is it configured to prompt for password?
share|improve this answer
Yes, sshd was running, and my firewall allowed ssh connections. – FabPelletier Mar 9 '12 at 15:50
I was not running SELinux (or if I was, I have not been able to find it). And my sshd settings allow root logins but doesn't prompt for password. – FabPelletier Mar 9 '12 at 15:56
Any clues in /var/log? – Scott Wilson Mar 9 '12 at 16:11
Sadly, no. As marked in the head of post, I think it was a problem with my network provider, as when I rebooted after some time and had a new IP address I was able to connect normally. – FabPelletier Mar 10 '12 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .