Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just installed Ubuntu 11.04 on to my girlfriends Acer Aspire One ZG8 netbook. It was running Windows XP before this, and was grinding to a halt.

Everything has been ok with it except it can't pick up my wireless card. It picked it up during the installation, but now on the home desktop when I right click on the networking icon, the drop down menu displays "Enable Wireless". No matter how many times I click on it it will not enable the wireless.

What should I do?

share|improve this question
    
Since you downvoted me, I deleted my answer since you're not going to accept my advice. I've tried various distros on over 6 laptops and only 1 of them with little to no problems. The rest had numerous update errors, having to reinstall losing all my data, missing or incompatible drivers that required massive amounts (days or weeks) of fiddling to just work. I'm not saying Linux is bad for many or anything of the sort. It's just not for really picky old or outdated laptops. I'm probably just very unlucky and ended up with a rather pro-windows bias but hey, that's just chance, ain't it. –  Valoric Mar 9 '12 at 11:42
    
I downvoted because your answer wasn't relevant. If the question was "should I use Ubuntu or Windows" then your answer is valid. But I wasn't asking for that, so hence your downvote. –  mickburkejnr Mar 9 '12 at 13:06
add comment

1 Answer

up vote 1 down vote accepted

I know that this works on Ubuntu 11.10, but don't know about 11.04

Open the terminal by pressing "Ctrl+Alt+T" and type the below code.

sudo rmmod -f acer-wmi

you want see any out put after pressing enter, Let's move on

sudo rfkill unblock all

Now this,

rfkill list all

After pressing enter you'll see an out put with all the option on the out put will say "on" if that happens then you're good to go and see the wireless connection which you'll see activated and will be listing your wireless connection name.

Keep in mind that the above would be a temporary solution. As soon as you rebooted, you would have to do the above steps again. Assuming that you don't know how to make this a permanent fix, do the following:

sudo echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist-acer-wmi.conf
sudo update-initramfs -u
share|improve this answer
    
Thanks for this, it does work. However, I get a "permission denied" when I attempt the blacklist command. Any ideas? –  mickburkejnr Mar 11 '12 at 19:47
    
I manually added acer-wmi to the blacklist.conf file. All working now! –  mickburkejnr Mar 11 '12 at 20:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.