Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 wired computers, and 3 wireless computers on a linksys router. The two wired computers run Windows Vista, and have no problems. I have a laptop with Win XP, which can connect via wifi without a problem. However, when either one of my Vista Laptop or Vista desktop connect to the network via wifi, the internet becomes briefly unavailable for all computers on the network. File and printer sharing still works. Sometimes my internet access is restored in minutes, sometimes I reset my router and cable modem to reset the connection. This happens without fail every time my laptop or desktop running Windows Vista connects to the internet. But only the first time, if I leave them on all the time it does not disrupt the connection. When a computer running vista is waken from standby, or if I logout and log back in, it also does not disrupt the internet connection of my house.

In a nutshell, it appears when Windows Vista connects to my wireless network this first time after reboot, it breaks my internet connection. This problem does not occur when macs, windows xp, or ipod touch connect to my wireless network.

Would anybody have an advice on this mystery, as I have tried to figure it out for the past 6 months. Have changed both my router and my cable modem to new ones without success. My ISP is rogers (in Canada).

Thanks in advance!

share|improve this question

migrated from stackoverflow.com Sep 11 '09 at 20:24

This question came from our site for professional and enthusiast programmers.

    
When you changed the router/modem to new ones, do you mean different make/model? Or same make/model, just... newer - what router is it anyway? –  Ciaran Sep 11 '09 at 21:23

1 Answer 1

Couple of suggestions to try:

  1. Do you have wireless security on the router switched on (i.e. WEP/WPA.. etc)? If so, temporarily disable it, restart the router and see you notice any improvement.

  2. Try disabling IPv6 on the Vista laptops and restart them. Reconnect, any joy?

share|improve this answer
    
+1 I would've said disable IPv6 too –  Ciaran Sep 11 '09 at 21:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.