Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My router runs dd-wrt and it assigns static leases to DHCP clients. The clients all use DHCP.

I recently changed the IP addresses I want assigned to clients. But the clients are not updating automatically. All clients are linux. Using "dhclient -r" doesn't seem to make any difference -- the client keeps the old address (unless I reboot it and the router).

I've had this same issue in the past with other routers (such as Netgear). I used to think it was purely a problem with Netgear's firmware, but now I believe I just don't know the the correct procedure or the rules by which IP addresses are updated when static leases are changed in the router. I'm seeking some explanations.

I have figured out that if I turn every off (including the router and all clients) and then boot the rotuer followed by the clients, everything will get the correct IP address. So I know how to resolve the situation. But short of that, the addresses don't seem to change, even if I wait long enough for the leases to expire. It seems like as long as a device remains connected to the router, its IP address will not change once it was assigned.

I've seen this behavior in different situations (mostly with the Netgear routers). It doesn't seem to matter if the IP was originally assigned dynamically or statically (DHCP static lease). It doesn't update while everything is still running.

Basically, I find it a real pain to have to shut off every client on my network to get IP addresses to update to a new scheme. Anyone have insights into this. I hope that if I understand it better, I'll find a more convenient way to deal with it.

(This issue is minor, but it has been bugging me for years. This time, rather than deal with it the same old way, I want to learn something new.)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It sounds like your DHCP server doesn't consider itself authoritative for the network segment it is on and is therefore not sending DHCPNAKs, which would instruct the clients to drop their old leases and go into the init state. Assuming you don't have two DHCP servers on the same segment, configure dd-wrt to be authoritative and the leases should start being dropped.

share|improve this answer
    
"DHCP-Authoritative" was unchecked. However, to enable it I have to enable some DNSmasq options that I don't understand. Looks like I need to do some more research. (BTW, I only have one router.) –  MountainX Mar 9 '12 at 1:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.