Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When installing software and in explorer.exe files don't show up as deleted! However, when I try and delete them again (with shift-delete), explorer says that "this file has already been deleted". Also when upgrading software, I sometimes get errors that old files cannot be deleted. Hitting 'retry' gets them successfully deleted.

Why are my files not immediately getting deleted. What is going on? Is this behaviour typical of a virus infection on Windows?

share|improve this question
Sounds more like a Microsoft "feature" than malware. Try hitting F5 to refresh your explorer window. – kobaltz Mar 9 '12 at 1:29
@kobaltz That's what I thought until programs were failing to upgrade, claiming they could not delete old files. Hitting retry fixed it. – unixman83 Mar 9 '12 at 1:50
Try CCLEANER to see if that helps. It will clean up your system and remove older temp files. – kobaltz Mar 9 '12 at 1:55
The first thing I would is try to rule out hardware failure or volume corruption. – iglvzx Mar 9 '12 at 1:57
up vote 0 down vote accepted

If you're so worried, download Malwarebytes and be done with it. Otherwise it's just a fault of the native explorer that comes with Windows. That or your computer is really, REALLY slow.

You could also try defragging your hard drive, if you never have, it can slow it down slightly. Try

  • Defragging
  • Cleaning your registry with CCleaner
  • Doing a drive wipe with CCleaner
  • Empty your temporary files
  • Analysing the health of your HDD
  • Error Check (restart needed)
share|improve this answer
I have a quad core Athlon II with 4 gigabytes of RAM. My computer is not slow. I also have Norton security suite with a current subscription. – unixman83 Mar 9 '12 at 1:49
This might be a stretch but you could try to check for Windows Error Check which you can find via the Tools on your Properties context menu on your C: drive. But first, do a defrag, it may find bad sectors as well. – Valoric Mar 9 '12 at 2:05
I highly advise against any form of registry cleaners without any proper knowledge of registry function and hive structure. Automatic registry cleaners usually do more harm than good. – Temikus May 6 '12 at 17:39
I'll absolutely agree with that. CCleaner has recently put me through a whole world of hurt by removing some integral key and spends hours trying to find the one that went missing. To prevent this sort of shit happening. ALWAYS BACKUP your Registry before "cleaning" it. In most cases, you shouldn't ever NEED to manually clean your registry. – Valoric May 7 '12 at 11:19

Seems that something went wrong with AutoRefresh settings of Explorer. You have two choices:

Try a registry modification:

  1. Launch Regedit and drill down to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update.
  2. Right click UpdateMode and choose Modify.
  3. Change the last two digits of the string of numbers in the lower pane to 00.

Recreate your user account and transfer over the settings:

  1. Here is a nice guide from Microsoft Answers:

P.S. Please, don't use Registry Cleaners, especially in automatic mode, they usually do more harm than good.
Also - Malwarebytes is not a substitute for a normal endpoint protection package, at least install Microsoft Essentials (delete Malwarebytes before that, though.

share|improve this answer
No reason to remove Malwarebytes before installing MSSE. Malwarebytes, MSSE, and SUPERAntiSpyware all behave well together, and Malwarebytes/SAS detect and clean a number of infections you won't catch with MSSE. – EKW Mar 9 '12 at 13:00
They can act together, doesn't mean they should. I agree that they can catch some of the spyware that MSSE can't, but if you want better protection, you should install a normal endpoint antivirus - McAffee, Kaspersky or ESET NOD. It would provide a lot more protection than this clumsy set of 3 apps. – Temikus Mar 9 '12 at 13:08
I would argue that any one of them are infinitely better protection than McAffee or NOD32. But not the place for such arguments. – EKW Mar 9 '12 at 13:13

I think one of my caches was corrupted. I ran CCleaner and the systems seems much more responsive. Hopefully that fixed the problem I was having.

share|improve this answer

I suggest complete AV scan (via Your Symantec), then scandisk (full) and for the end defragmentation of system partition.

Delay "feature" while deleting files is common issue, but errors with upgrading software might be caused by malware. If above things wont help You, turn off Symantec (for a while) and start Combofix reparir.

Combofix howto:

Combofix scan&repair may last hour or more, so be patient :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.