Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

At work, all requests are forwarded to a central load-balancing, caching Squid proxy server. If I try to access Facebook from within Firefox, I get the standard proxy authentication dialog:

The proxy moz-proxy://<IP addresss> is requesting a username and password. 
The site says: "moz-proxy://<IP Address>"

However, this dialog comes only for facebook & only when accessed from Firefox - any clues as to why this happens? Accessing from Internet Explorer or Chrome works fine, and yes Facebook is not blocked.

Just Firefox gives this problem. I have installed NTLM Auth for Firefox addon, but it hasn't helped.

The proxy settings are set to auto detect, same as in Internet Explorer & Chrome.

I'm using the current stable version of Firefox, 10.0.2 on Windows XP SP3

share|improve this question
@Sathya: Perhaps they are attempting to block Facebook? Hear if it also happens for other employees using Firefox (as I suppose hearing at the IT administrator if the company's policy has changed is kind of not what you want to be doing). – Tom Wijsman Mar 9 '12 at 7:07
@TomWijsman it isn't blocked - I've mentioned it works fine on IE & Chrome. – Sathya Mar 9 '12 at 7:09
@Sathya: Strange that it only happens in Firefox though, you might get around using IE Tab. (Please note that there are multiple IE Tab add-ons and I'm unsure which is the right one or which works...) – Tom Wijsman Mar 9 '12 at 7:11
And this is only happening on a single computer? – iglvzx Mar 9 '12 at 7:26
@iglvzx it's my work system - I don't have other systems to test it out – Sathya Mar 9 '12 at 7:31
up vote 15 down vote accepted

Most probably, your proxy is blocking the WebSocket protocol. Chrome before version 14 and IE don't support it, so they are not affected.

Go to the URL about:config, search for the key network.websocket.enabled and switch it to false.

share|improve this answer
This worked for me, FF 14.0.1. problem was specifically with! – Christopher Mahan Aug 21 '12 at 22:19
Hoorah! This has fixed my problem, at last I can use stackoverflow without having to resort to IE! Thanks! – DaveRlz Oct 15 '12 at 8:31
You are my hero. <3 – Christopher Parker Dec 7 '12 at 21:14

I've been having the same issue for a while now. It's a bug specific to Firefox, and only when accessing Facebook addresses through a proxy. This page itself, for instance, brings up the dialog a total of 10 times, taking 10 clicks before I can dismiss it and go about my business.

I have since downgraded to Firefox 4.0.1, which fixed the issue. It's not a great workaround, but it's there.

EDIT: It turns out that last bit was premature - I've now started experiencing the same problem on 4.0.1.

share|improve this answer
Facebook: "We're on to you, jcarter!" :P – iglvzx Apr 10 '12 at 0:53
This problem is quickly driving me insane - what's worse is that Chrome flatly refuses to install on this machine, so don't have the option of using it in the interim. – jcarter Apr 10 '12 at 1:06
Which operating system? If Windows, you can try Google Chrome Portable. – iglvzx Apr 10 '12 at 1:13
Thanks, that fixed the installation problem, but I still have a persistant issue with Chrome where it becomes stuck "Sending request..." and never loads the page. That's a story for another SU question though. – jcarter Apr 10 '12 at 3:26

I Just tried the suggestion in the accepted answer and I'm afraid it didn't fix my problem, as well as these other suggestion which also didn't work: (These solutions may be currently outdated)

However, while browsing the aboug:config page I found this entry:


If this is set to TRUE the prompt does not appear anymore.

BTW: It does only work if you log in at least once. If you cancel it, it keeps appearing.

And, as a consequence, if you use the private browsing feature (I use it at work, for personal stuff: e-mail, etc.), every time you start a new private session you have to accept the login prompt. Not a big problem though...

share|improve this answer

Firefox 8 added Origin tag for images, which has caused some specific proxy issues. If Facebook works for you with Firefox 7, I would say it's a bug in Firefox.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .