Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run this command via FTP in order to delete some files I have stored in a folder in my website:

DEL *.csv

However this doesn't work and I don't know why. However if I try to delete every single file this works:

DEL file.csv (works)

How could I do in order to solve this issue?

share|improve this question

migrated from Mar 9 '12 at 6:08

This question came from our site for professional and enthusiast programmers.

3 Answers 3

up vote 9 down vote accepted

If you're using the Windows command-line ftp client, then you will need to use mdelete to delete multiple files, as delete will only delete a single file.

Edit: Answering the additional questions in the comments.

If you want to put these commands in a file so that you can perform them as some kind of batch process, you could create a text file and put the commands in sequence there:

mdel *

Then you could run this as a single step with the -s parameter.

share|improve this answer
As a side note, the MS command-line client also supports mput for putting multiple files up at a time (mput *.dll). – Lynn Crumbling Mar 8 '12 at 15:57
Thanks, it works fine!!! However if I write MDEL *.csv it asks the confirmation, I would do this automatically without confirmation, how could I do this? – F G Mar 8 '12 at 16:09
I've not tested it, but you might try putting the mdel command (and possibly the "yes" response that mdel wants) inside a text file and then using the -s option to load the ftp commands from the file. – Canute Bigler Mar 8 '12 at 16:18
Thanks but where should I put the yes response? – F G Mar 8 '12 at 16:23
use prompt to switch interactive mode off before using mdel – MBu Mar 8 '12 at 16:32

To use mdelete use the syntax below to automate the process

At the FTP> use the "prompt" command to disable interaction (mode off)

Type this command:

  • FTP> mdelete [directory] *.extenstion |yes

For example, mdelete standard *.jpg |yes

share|improve this answer

DEL will then ask you to confirm that you want to delete all file

try this

FOR %%A IN (*.csv) DO DEL %%A
share|improve this answer
its a dos command not Ftp one . the OP is asking for FTP. – Royi Namir Mar 8 '12 at 15:54
technically Canute Bigler's answer ("mdel") is not a ftp cmd either, it is just windows ftp client cmd and not a standard ftp cmd. – Logman Jun 10 '12 at 16:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.