Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've come across two maxtor external drives. One is a 250GB OneTouch 4 mini. The other is a 60GB OneTouch 3 mini. I plug them into my windows 7 box and nothing happens. The 60 gb one starts beeping. I assume this means there are not formatted correctly perhaps.

I plug them into my mac and they are recognized quickly. I format both the drives to fat with disk utility. I plug them back into my windows machine. Still nothing. Still beeping on the smaller drive.

I'd like to get these on the windows 7 box and format them for ntfs. Are there other disk utility software I should be trying? On the windows box in device manager they do not even show up as unknown devices. Any ideas?

share|improve this question
    
is the problem limited to these 2 drives? do other usb drives work properly? –  Molly7244 Sep 11 '09 at 21:51

2 Answers 2

Not sure if this still happens in Win7 but in XP a friend had the same problem and removing all USB devices in device manager did the trick. After they were removed windows found them again and added them in the list and external drives were recognized after that.

share|improve this answer
    
+1 has worked for me in the past. It's in the same class of "solution" as "reboot windows" but it does help sometimes. –  boost Sep 15 '09 at 1:43

You may want to check the partition scheme of your disks. GUID, MBR or Apple partition map. The most portable is MBR, but I suppose that GUID is ok as well. You can select this with the options button on the partition sheet in Disk utility.

share|improve this answer
    
It is listed as GUID. I do not see anywhere to change this setting. –  CT. Sep 11 '09 at 21:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.