Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm too bored of seeing sites like Google and such show up in my native language, I would rather like them to be in English. Yet, I have to explicitly change the URL to .com and en and that kind of parameters in order for them to show up in English. Can I somehow force this?

So, how is Google configured?

However, it is set to English on the site itself so it has to be my browser:

Then, how does my browser land up on non-english pages, like Google?

It usually shows up in non-English when I'm performing a search, which uses:

{google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}{google:searchFieldtrialParameter}{google:instantFieldTrialGroupParameter}sourceid=chrome&ie={inputEncoding}&q=%s

When performing a search, it fills these variables in with non-english values.

How can I tell my browser to fill these in with the English values?

My Google Chrome options give preference to English:

share|improve this question
    
I'm sure that this has been asked before, but I can't find the duplicate right now. –  ChrisF Mar 9 '12 at 10:39
    
When you go to google.com, does it redirect you? What happens if you click the "Use google.com in English" link (or similar) at the bottom? –  slhck Mar 9 '12 at 10:58
    
@slhck: It doesn't redirect me if I do that, in that case it is in English. If I click the link it doesn't remember that for the next time. It is really Google Chrome that literally fills in {google:baseURL} with https://www.google.be/... –  Tom Wijsman Mar 9 '12 at 11:00
    

3 Answers 3

There are two options available for configuration:

which language should Google products use

which language(s) should be used for search results

Open Google Chrome, in address bar type in: http://www.google.com/preferences#languages

You can configure more than 1 language for search results, while only 1 can be set for Google products.

Configure appropriate settings and Save them.

enter image description here

share|improve this answer
up vote 5 down vote accepted

In %LOCALAPPDATA%\Google\Chrome\User Data there is a file Local State which contains the {google:baseURL} information. While temporarily closing Google Chrome, I simply filled in the URL https://www.google.com instead which resolved my problem:

{
   "browser": {
      "enabled_labs_experiments": [ "conflicting-modules-check",
                                    "extension-apis", "preload-instant-search",
                                    "print-preview" ],
      "hung_plugin_detect_freq": 2000,
      "last_known_google_url": "https://www.google.com/",
      "last_prompted_google_url": "https://www.google.com/",
      "last_redirect_origin": "",
      "plugin_message_response_timeout": 30000
   },
share|improve this answer
2  
What name it is in Lion? I can't see Local State file in Application Support. Thanks. –  Wojciech Bednarski May 29 '12 at 3:25
    
@WojciechBednarski: ~/Library/Application Support/Google/Chrome else I don't know... –  Tom Wijsman May 29 '12 at 11:21
    
This is only for Chrome; the answer by Volodymyr works for all browser. –  Jeroen Wiert Pluimers Jul 8 '13 at 7:38

If you use Chrome, you can force all Google services to use English with this extension: https://chrome.google.com/webstore/detail/english-please/lkhoknaphajfjdcpnllakeglfpbbimhp

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.