Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using windows 7 64 bit ultimate edition.

i ran my pc. windows opened. on the top i see language bar. which shows that there are two languages present one is english and other is russian.

Windows Load

After that i go to language settings. Here i see that only english language is there. there is no russian language present.

Keyboard settings

there is no russian keyboard here but i still see language bar. then i add russian language in to the list, applied it, and then remove russian language from the list and then i click ok. now russian language is gone. what should i do that it doesnt load at the start.

share|improve this question
    
Are you using a legal non-hacked version of windows 7? –  G Koe Mar 8 '12 at 1:04
    
I am not sure what your actual question is. Can you be more explicit? –  Shinrai Mar 9 '12 at 16:33
    
@Shinrai when i start my windows then it is shown that two input language (keyboard layouts) are loaded. one is english and one is russian. point to ponder is that i havent added russian language. When i go to keyboard layout settings it shows me that only english is in the list and there is no russian. but the language bar shows me russian is present as well. in normal case if u have only english language as input language bar doesnt show. but in my case only english is in the list but i see two languages. –  Faisal Hafeez Mar 9 '12 at 17:07
    
i want to know how to get rid of russian language permanently. what now i do is everytime i start my pc i go and delete russian language, –  Faisal Hafeez Mar 9 '12 at 17:08
    
This happens by default if you set your language to English and your locale to Russia. It's for currency, time, etc, not the actual interface language - that's why the keyboard is only English. I assume you want your locale to stay Russia, so just do what HaydnWVN suggests in that answer to hide the language bar. –  Shinrai Mar 9 '12 at 17:25
show 5 more comments

3 Answers

FYI (Everybody), if you run a Windows 7 version that doesn’t support multi-language you won’t be able to use the Multilingual User Interface (MUI) functionality to change the default language for Windows 7 welcome screen. Fortunately, MUIs are available in Windows 7 Ultimate and Enterprise edition.

Basically, you are able to change that only when the Keyboards and Languages tab in Region and Language setting looks like below.

enter image description here To change the default language on welcome screen

Go to Administrative tab in Region and Language window, which can be launched from Control Panel, and click on Copy settings button.

enter image description here

You will see what the current language settings on Current user, Welcome screen, and New user account.

enter image description here

To make the default language setting on Welcome screen the same as your current user account, simply check the option “Welcome screen and system accounts” at the bottom.

enter image description here

Click OK to save the setting, and reboot the computer for the change to take effect.

share|improve this answer
    
You get it wrong. I am saying about input language. superuser.com/questions/398905/russian-language-in-windows-7 see this question, i have explained it with images, hope you will get it, –  Faisal Hafeez Mar 9 '12 at 16:25
    
I Understand now - please see my respons to your new question. –  G Koe Mar 10 '12 at 4:57
add comment
  1. Click"Start", then "Control Panel"
  2. Hit "Date, Time, Language, and Regional Options", then "Regional and Language Options"
  3. Press "Languages" tab, then "Details" button
  4. Choose "Langage Bar" button at bottom, and then uncheck "Show the language bar on the desktop"
  5. Press "OK" and the Language Bar will be gone Note: You can always just recheck to enable it again

If you really want it gone so you can't ever see it again:

  1. Go to "Start", then "Run"
  2. Type "Regsvr32.exe /u msutb.dll" and press enter
  3. The Language bar will never bother you again

Note: The "Language Bar" button described above will be grayed-out (unaccessible) for good as well, meaning you can never renable it.

Source

share|improve this answer
    
russian language is automatically loaded on system restart. i want that it doesnt load, –  Faisal Hafeez Mar 9 '12 at 17:15
    
It looks more like you've got a windows corruption or using a hacked/cracked version of Windows - my instructions will disable the language bar which will fix your 'problem' regardless of the cause. –  HaydnWVN Mar 12 '12 at 9:05
add comment

run LPKSETUP from the run box or a command prompt - it starts the same program to maintain the lp.cabs on your machine, as the "regional and language settings" in control panel.

  1. Choose "uninstall language pack"

Language Pack uninstall screen

  • Now click on Remove languages option

  • Select the language you want to remove and click Next button

  • Follow the instructions thereafter.

share|improve this answer
    
i clicked remove langauges but it shows only english language. not russian language is there, –  Faisal Hafeez Mar 10 '12 at 5:47
    
if you got to Control Panel>Region and language, what is the "Current location" set to on the Location tab? If you click the link for "Default location" on the bottom of the location tab window, what is your "Default location" set to? –  G Koe Mar 10 '12 at 6:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.