Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am getting a BSOD Error when Running Windows Phone 7.1 Emulator on Windows 7 Ultimate 64bit, Each time I run the Emulator, it Results in Blue Screen. This is a Fresh Install, This Error also Occurred with my last Windows Install (That is why I formatted the Windows Again), I have already Tried to Re-install it, it also shows "Windows Phone Emulator is Doing a Complete OS boot" (Even at Fresh Install, I know it happens when using Unlocked Emulator Images). I am not able to Test any of my app. Please Help !!

EDIT: I am not Running a VM, it is on a Physical Machine.

share|improve this question
add comment

4 Answers

I would be looking to get the memory dump from the BSOD, and analyse it using WinDBG (which is installed as part of the Debugging Tools For Windows in the SDK).

This should tell you a bit more about what is causing the BSOD. Failing that, an indication of what the bugcheck code was (and which parameters it had) will also help point you in the right direction. You can look up bugcheck codes at: http://msdn.microsoft.com/en-us/library/hh406232%28v=VS.85%29.aspx

If you don't remember the bugcheck details, and don't want to reproduce the issue again, take a look in the eventlog (eventvwr), in the system log. There will probably be an event from the source 'BugCheck' in there with the details.

A memory dump, loaded in WinDBG is the only way to be sure.

share|improve this answer
    
I already thought about that but I really don't know why there are no dump files on my system. –  Akshat Mittal Mar 10 '12 at 8:52
    
Is it configured to write a memory dump when it crashes? Was there an event from 'BugCheck' in the system log? –  Adam Thompson Mar 14 '12 at 16:46
    
Yes it is Configured, While in BSOD, it Shows for Writing Dump –  Akshat Mittal Mar 15 '12 at 9:22
add comment

I am getting exactly the same problem - I hit F5 to debug in the WP7 emulator and immediately I get a BSOD STOP 0x0000001E (0,0,0,0) message. This is on 64-bit Windows 7 SP1 machine. I've not used WinDBG before but I'll take a look.

[EDIT] Note that I had it working before so I'm not sure what has broken it. I do have a bugcheck entry in Event Viewer. I'm installing all the latest Windopws Updates now to see if that helps but I don't have high hopes.

[EDIT2] Nope - I'm now up to date with Windows Updates and it still does it, reproducibly, every time. WinDBG indicated it occurred somewhere in vmm.sys.

share|improve this answer
add comment

I got it too. When you disable VT in the BIOS, the crash does not happen (but of course the emulator will run without acceleration).

Seems like a bug MS should fix.

share|improve this answer
1  
Exactly. Disabling the VT-x (Virtualization) in BIOS Fixes the Crash but the Emulator has a Decreased performance (No Acceleration). –  Akshat Mittal Jun 2 '12 at 7:28
add comment
up vote 0 down vote accepted

Disabling VT-x (Virtualization) does not give this error but the Emulator runs on a lower performance as acceleration is not present. For running emulator with VT-x, deleting all app preferences and emulator images then re-installing the Emulator helped solve the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.