Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I switch into Full Screen (F11) in chrome it says "You've gone full screen. Exit Full Screen (F11)".

Can I disable this from showing up? I know how to exit full screen.

share|improve this question
    
possible duplicate of Can I make Google Chrome allow fullscreen by default? –  David Silva Smith Feb 15 at 13:28

3 Answers 3

up vote 5 down vote accepted

I'm pretty sure that it's impossible to suppress this message because this could be a potential security problem (you could fake a desktop and intercept the input of the user).

You could search the chromium source for a flag or something to disable the message. I looked into a few files with the string "Exit Full Screen" but due to my limited experience in C/C++ I gave up after two minutes.

share|improve this answer
6  
Sorry, but I fail to see the security problem here. 1) The user initiates going full-screen, it's nothing that happens automatically. Why do I need to watch at a box telling me that I pressed F11 after I just actively pressed F11? 2) If the full-screen view would try to fool me and display a desktop which looks like mine I would see the smaller desktop before, since going full-screen does not change the web page. I don't see a security problem here. –  Marco Oct 9 '12 at 7:46
3  
In some cases, it is possible to expand a window to full screen with JavaScript: stackoverflow.com/questions/1125084/… - Some users may not understand what's happened, which is a security risk. It used to happen fairly frequently, before newer browsers started adding confirmation steps. –  meetar Feb 12 '13 at 19:18
23  
So then show it, but have a "don't show this again" button or a setting to disable it. Once you know what you're doing, it's odiously bad UX. –  Calvin Fisher Apr 30 '13 at 13:55
3  
There should at least be a way to whitelist certain sites. I trust YouTube to use fullscreen responsibly. –  Tom Crockett Oct 21 '13 at 2:20
    
It could just be in the corner and I wouldnt mind, but its in the way ! –  HaveAGuess Feb 17 at 23:05

This can be accomplished by starting Chrome in kiosk mode.

Here are instructions on how to do this: http://think2loud.com/868-google-chrome-full-screen-kiosk-mode/

Here are steps for running Google Chrome in full screen Kiosk Mode on a Windows PC:

  1. Right click on your Desktop and go to New > Shortcut

  2. Browse to the chrome.exe file (depending on your set up, it might be found here: usernameAppDataLocalGoogleChromeApplicationchrome.exe) and click Next

  3. Type a name for the shortcut (ie “Chrome Kiosk Mode”) and click Finish

  4. Right click on the new shortcut on your Desktop and go to Properties

  5. At the end of your Target replace chrome.exe with “chrome.exe –kiosk http:// [enter URL here]” and click OK

  6. Double-click the shortcut on your Desktop and it will launch the full screen Kiosk

  7. To quit the Kiosk, press Alt + F4 on your keyboard.

share|improve this answer
2  
Caveat: this only seems to work if you don't already have a Chrome window open... and once you open one window in kiosk mode, any new windows you open will also go to kiosk mode, even if you open them as a different Chrome user. –  Calvin Fisher Apr 30 '13 at 13:59
1  
Best workaround if you have other Chrome windows open: superuser.com/questions/423272/… –  Calvin Fisher May 2 '13 at 18:55

FYI, here's a solution.

As a summary:

  • Go to: chrome://settings/contentExceptions#fullscreen
  • Replace any existing URL with: [*.]

The entry will disappear, but it should still work.

Source of pattern: https://support.google.com/chrome/answer/3123708?p=settings_manage_exceptions&rd=1

share|improve this answer
1  
Hm, the entry disappeared but it's still doing the notification, even after restarting chrome. Wonder if it's been patched out –  Ben Brocka Aug 21 '14 at 13:53
    
What version are you running? It worked on OS X for Chrome 36. –  jp.rider63 Aug 22 '14 at 15:24
    
@BenBrocka Change the pattern to [*.]. –  108 Jan 11 at 2:35
    
For reference, the original pattern match was: *://*/*. Looking at your reference, it doesn't make sense that [*.] would work to me. To me, it means that Chrome will optionally match a URL with any characters followed by a period. Maybe this works though. –  jp.rider63 Jan 12 at 1:21
    
Now that I think about it, maybe *://* would work better? –  jp.rider63 Jan 12 at 1:25

protected by Community Jan 11 at 2:28

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.