Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the Charles Web Debugging Proxy software to debug HTTP requests. It works great with my desktop browsers, Chrome and Firefox, and it even sees HTTP requests that other programs make.

When I run Charles and check the network config, I think I understand how it works - it just sets up a proxy for all HTTP and HTTPS requests and then listens for these on port 8888:

Picture.png

However the item I can't figure out is that I don't see any requests that I initiate at the Terminal, such as wget, curl, or the elinks browser.

I know that I can specify the proxy with curl and wget by using 127.0.0.1:8888, but I don't understand if the nextwork interface is set up with a proxy in the configuration why I would need to manually specify the proxy for them.

Also I can't seem to get BlueCrab (website copier) to show up in Charles either - and I dont' see a proxy setting for it - although I believe it is using an XWindow wrapper or something (so it's not really a native Cocoa / Carbon app):

Picture 1.png

How can I get all HTTP requests on my system to run through Charles?

Clarification

My question is about the system fundamentals of why curl and wget wouldn't use a proxy when the network interface was set up to use one more so than asking about the correct syntax for curl, wget, etc.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

VPN would create a new network device, you can see it in ifconfig command, and then route all system network to that device, you could see the route use route command.

But HTTP Proxy (in this case, the Charles) is different, it just open a port, to use it, you must specify your application setting to use that port for HTTP stuffs. and as Kevin Reid's answer, curl, wget etc don't read OS X's system wide settings.

If your proxy is SOCKS (and Charles supports SOCKS), you could use tsocks or ProxyChains for application doesn't support proxy setting:

tsocks APPLICATION_COMMAND
share|improve this answer

The reason why you don't just get proxying of all HTTP requests is because at the operating system level, there is no such thing as a "HTTP request"; there are only TCP connections. Contacting a HTTP proxy means changing the HTTP request slightly as well as contacting the proxy server instead of the host named in the URL, so it has to be done in the code that implements sending HTTP requests.

curl and wget have their own HTTP code, which uses their own config files — they haven't been programmed to look for proxy settings where Mac OS X keeps them, nor are they using the HTTP libraries provided with Mac OS X that use those proxy settings.

share|improve this answer

wget behind proxy (you may have to create the rc file) source

`$ vim ~/.wgetrc`

Add the following line:

http_proxy=http://127.0.0.1:8888

curl behind proxy source

$ vim ~/.curlrc

Add the following line:

proxy = 127.0.0.1:8888

elinks behind proxy source

Find your elinks.conf file with:

sudo find / -name elinks.conf

Add the following line:

protocol.http.proxy.host "127.0.0.1:8888"

Not sure about BlueCrab

share|improve this answer
    
> I know that I can specify the proxy with curl and wget by using 127.0.0.1:8888, but I don't understand if the network interface is set up with a proxy in the configuration why I would need to manually specify the proxy for these things. –  cwd Mar 10 '12 at 0:08
    
Your question title and what you were looking for don't match. I will try to find that info as well, though. –  Dez Mar 10 '12 at 0:15
    
I think it does match - I am looking for a way to run ALL requests through Charles Debugging Proxy and not have to set up rules on a program by program basis. Don't worry if this question goes stale and nobody else can answer it I will come back and accept your answer. And thank you for sharing the config syntax for those utilities. –  cwd Mar 10 '12 at 0:27
    
After reading your edit I now see where I misunderstood your original request. –  Dez Mar 10 '12 at 3:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.