Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My speakers are working even when I plug in my headphone to the front jacks. So I hear sounds from both headphones and speakers. This is quite annoying.

How could I fix this? What could cause this problem?

I'm using Realtek HD Audio Manager in Windows 7. My motherboard is a Sapphire Tech PI-AM3RS785G.

share|improve this question
What make and model is your laptop? (msinfo32 will show you) –  kinokijuf Mar 10 '12 at 11:28
@kinokijuf I added my mainboard model info. I am using desktop –  AnyOne Mar 10 '12 at 11:31
First off, make sure your headphone plug is not undersized. Try using a headphone extension to get a different plug. –  Daniel R Hicks Jun 28 '13 at 11:19

5 Answers 5

I have been looking over and over for the answer and keep getting information that has to do with buttons and options I don't have on my computer or steps that were just missing. Here is what I found.

Press Start.

Press Control Panel on the right side. (If it took you to Control Panel > All Control Panel Items; Press on Control Panel in the address bar at the top)

Press Hardware and Sound

Press Sound

This should give you a dialog box labeled Sound with 4 tabs labeled Playback, Recording, Sound and Communications.

While under the Playback tab; Plug in and Unplug your headset while looking for the Speakers that are going from Not plugged in to Ready. Click on the Speakers once you figure out which one it is.

Press Set Default at the bottom

Press Apply

This should set your head set to default while they are plugged in and go back to your other speakers when they are not.

share|improve this answer
some screenshots would be nice here. I know what you're talking about but this would improve the answer a lot. If you lack sufficient rep, just add links to the images and someone should edit it in. –  Journeyman Geek Jun 6 '13 at 15:15

Open audio manager, on right top side there's "Device advanced settings". Click it and check if "Mute the read output device, when a front headphone plugged in" is selected.

Then click on "Connector settings", in my version ( it's the yellow button under the device advanced settings, and check that "Disable front panel jack detection" is not checked.

If it still doesn't work check if you have headphones connector on the speakers and use that instead, that should mute the speakers.

share|improve this answer
There is no "Devide Advanced Settings" in my realtek driver software. Someone has exactly same problem please check this… –  AnyOne Mar 10 '12 at 21:34
According to this:… you can check Bios and try to set HD audio to Enabled, then install drivers again. I think your MB should have this setting in Bios. Other than that I suggest you contact Realtek or MB manufacturer. –  T. Kaltnekar Mar 10 '12 at 22:36
It is enabled in bios setup and i reinstalled driver again but no luck. I asked question in sapphire forum now. –  AnyOne Mar 13 '12 at 22:11

Try this, I found it on some other forum and it worked for me, Check with volume settings.

  1. Right click on the speaker icon in taskbar and select volume control options.
  2. put a check mark on "All devices currently playing sound".
  3. Make sure you have "The default communication device unchecked".
  4. place a check mark on both speakers and headphones.
share|improve this answer
This led me to fix my problem, only, I checked "The default communication device" and unchecked everything else. –  Idrees Jun 29 at 11:40

I have this on my laptop, too.

Right-click on the speaker symbol, choose playback devices and select headphones (might only be there if headphones are inserted) and click on use as standard.

The exact wording might vary, since I only have a German version of windows 7 installed.

share|improve this answer
Does not eppear my headphone device in playback devices When i plug in my headphone to front jacks –  AnyOne Mar 10 '12 at 12:13
Strange, was the only explanation I could give. My Laptop will always show the headphones and speakers as two different devices and when I plug in my usb audio card others appear. It also only happended since Windows 7 (maybe Vista, skipped that one), not XP - IMO no reason for a down vote though –  Mene Mar 10 '12 at 14:29
I have not down vote you so someone have a reason to down vote you –  AnyOne Mar 10 '12 at 21:55

Plun and unplug the 3.5mm jack many times from both mike and headphones worked for me after I plug/unplug 8 times .

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  DavidPostill Mar 20 at 6:10

protected by Nifle Mar 20 at 17:10

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.