Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently reinstalled Windows 7, and all the files on the backup hard disk I use are exclusively set to ownership on my previous admin account. How this occurred, I have no idea, but now I can't access my own files. Using my new admin account, I set the ownership to the new account and then set myself to full permissions. But when I changed the settings on a folder, some of the contents recursively updated but others did not- I have to change every one of these files and folders manually, of which there are a great many. I tried setting myself to act as part of the operating system in the Local Security Policy, but again, this has only worked to grant access to some of the files. There are still many more that I can't access.

I need to wipe all trace of the previous administrator account from all files and folders on the hard drive and grant myself all permissions.

Any suggestions as to how I can eliminate this problem?

share|improve this question

If you mount your drive in Linux, the permissions will be pretty much ignored if the files are not encrypted:

  1. Boot from a live CD
  2. Copy files to a location that doesn't understand NTFS permissions, e.g., a FAT32 partition or USB stick
  3. Copy them back to a new location on the original NTFS partition that has its file permission set properly
  4. Boot back into Windows.

Any live CD that can mount NTFS will do here. Ubuntu works from my experience.

My solution is a bit blunt, I'd be curious to see a batch file or script that repeatedly calls icacls and/or takeown.

share|improve this answer
Turns out that there's a button in Windows which does take ownership recursively in all conditions. Thanks for the answer, but it's not what I ultimately went with. – DeadMG Mar 11 '12 at 14:53
Glad you got it sorted out. – krlmlr Mar 11 '12 at 15:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.