Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a Lenovo IdeaPad Y450A-PEI laptop with an Arch Linux installed on harddisk. I used to have a Windows 7 and a Fedora on it and they're fine.

Now I'm trying to install Windows 8 but when it goes into boot screen (with a super ugly fish) it stucks there. Those dots at the bottom of the screen move a bit and stop for a long time, then move a bit again. After approximately 30 minutes I'm able to get into Setup screen. Setup is fine, but after reboot it stucks just like before.

I also try Windows 7. Same, it stucks at the glowing Windows logo (should be an animated one), after a long time there's Setup, and reboot, another long time, Setup continues, another reboot, then stuck. I have no patience to wait for more than 15mins. Going into Safe Mode only tells me that it stucks at CLASSPNP.SYS.

Changing BIOS option AHCI to IDE: no luck, but when loading CLASSPNP.SYS a BSoD flashed and reboot. Also no luck in Setup.

I've tried nearly all possible solutions but none of them worked.

share|improve this question

1 Answer 1

Try to replace your hard drive and then check if it works. If it does, then you have a problem with your hard drive.

You could also try to buy an external kit for your hard drive and then recover your data from it.

share|improve this answer
    
That Arch Linux works well, can I say that there's no problem with the harddisk and why? Many thanks for further explanation. –  hexchain Mar 12 '12 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.