Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After installing Snow Leopard onto my Mac Pro, I found I was unable to print to either one of my printers, and HP LaserJet, or a Canon iR C3220-C1. So how do you get them to print again? I'm answering my own question below because I couldn't find anything to help getting mine working.

share|improve this question
    
Did you have this solved before you even started typing the question? – Troggy Sep 11 '09 at 23:15
    
Yeah, but it won't let me accept it yet – emgee Sep 13 '09 at 20:47

Apple just released updated Snow Leopard printer drivers for HP printers today (9/11/2009). You can install them through Apple Software Update.

share|improve this answer
up vote 0 down vote accepted

The HP was simple. First I ran software update and installed the HP printer driver update. However, it still said it needed updated software after this, so I removed the printer and reinstalled it. It printed perfectly after this.

The Canon was a bit tougher. I downloaded and installed the Canon printer driver update, but this probably didn't make a difference because the iR C3220 is not a supported printer on the Apple site.

Next I downloaded a fresh copy of the driver from here imagePASS-C1v2.1_PPD_Intel_MacOSX.hqx

It installed correctly, and I removed the printer and reinstalled. Tip: the printer doesn't show up using Appletalk anymore, so when you add the printer, choose IP on the top, select Line Printer Daemon - LPD. Type in the printer's IP address. For the Queue, type in print. Under Print Using, choose the Canon iR C3220-C1 ppd.

It still wouldn't work, so I checked the cups error log file. From terminal, type:

tail /var/log/cups/error_log

The error I was receiving was:

Filter "/usr/libexec/cups/filter/fierycupsfilter" for printer "_11_22_33_44" not owned by root

The fix was easy enough:

sudo chown root:wheel /usr/libexec/cups/filter/fierycupsfilter

I had to remove the printer and add it again, but after that it worked.

I found absolutely nothing when searching for this on the internet, so hopefully this helps someone else who may be using this combination. There may be similar problems with other fiery-based printers.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .