Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Latitude e6420 xfr (Windows 7 Ultimate 64-bit, i7-2640m CPU with 8GB memory) with a dock from Dell.

I am using the laptop display as the main display with Intel HD graphics 3000 and two external monitors (Dell U2212HM) with NVIDIA nvs 4200m (maximum resolution of NVIDIA: 2048 x 1536 from spec. of NVIDIA). I connected two monitors with separate DVI outputs on the dock.

When I set up NVIDIA Control Panel as below:

  1. Laptop display: 1366x768 (native, maximum resolution of laptop display)
  2. First monitor: HD, SD 1080p, 1920 x 1080 (native, maximum resolution of monitor)
  3. Second monitor: HD, SD 1080p, 1920 x1080 (native, ")

all displays worked well for a few seconds, but I encountered a blue screen. When I use dual display with laptop display and one monitor, I could use maximum resolutions for each displays and there was no blue screen.

To solve this problem, I lowered the resolutions of the monitors from 1080p, 1920 x1080 to 1080p, 1680 x 1050. After that, all displays were working for a week.

However today my laptop stopped working suddenly. I had to restart Windows. All display are working right now.

I don't know if this issue came from the multi-display setup and it will happen again or not. I also want to use maximum resolutions for both monitors.

Please check my symptoms and let me know your opinions.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.