Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've ordered a Raspberry Pi, but I'm on a long lead time and I'd like to start playing today!

I've downloaded the disc image, tried to boot it in Windows 7 Virtual PC and it doesn't work. Of course, it's because those images are built for the ARM CPU and I'm running a 64-bit version of windows 7.

So, I think the root of my question is, can I run a virtual PC which emulates a different CPU architecture under Windows?

I'll happily change the Virtual PC software I'm running! I expect that's essential.

Any advice would be gratefully received.


share|improve this question
I know QEmu can emulate an ARM on your PC. I don't know if it's close enough to the RPi to allow you to run RPi software. (Yes, it can be made to work, at least on Linux.) – David Schwartz Mar 11 '12 at 12:29
This is going to take some serious reading! – G-. Mar 11 '12 at 22:39
try using the development vm that can be found here… . i havn't tried it yet but maybe it will work for what you need. – user122529 Mar 12 '12 at 3:59
Please note there is a Raspberry Pi proposal on Area 51. Please follow if you have not done so already ...… – iandotkelly Apr 10 '12 at 18:34
I've committed to the proposal – G-. Jun 2 '12 at 12:03
up vote 2 down vote accepted

This should work: Emulating Raspberry Pi in Windows the easy way

Direct link to download: Raspberry Pi emulation for Windows

Just download the folder, unzip and run the batch file – then follow the supplied instructions to login etc.

share|improve this answer
Just trying this now – G-. Jun 2 '12 at 11:33
Works flawlessly! – G-. Jun 2 '12 at 11:55

I got both the latest Debian and ArchLinux images to load using QEMU running under Windows 7 x64 with the following command lines:

qemu-system-arm -kernel kernel-qemu -cpu arm1176 -M versatilepb -serial stdio -append "root=/dev/sda2 panic=1" -hda debian6-19-04-2012.img -clock dynticks


qemu-system-arm -kernel kernel-qemu -cpu arm1176 -M versatilepb -serial stdio -append "root=/dev/sda2 panic=1" -hda archlinuxarm-19-04-2012.img -clock dynticks

Just grab the latest QEMU binaries and download the distributions.

EDIT: The kernel I got to work was the kernel.img file from the SD Card image of the Debian distribution. I had to copy this file from the SD card to the QEMU program directory.

share|improve this answer
Hi, this answer looks the most promising so far but unfortunately didn't work straight out. The installer didn't include qemu-system-arm.exe I've grabbed the files individually from the folder but now get "kernel-qemu: No such file or directory I cant find any kernel files on that repository qemu: could not load kernel 'kernel-qemu'" – G-. May 12 '12 at 16:29
Is it looking for a kernel within the image file? – G-. May 12 '12 at 16:35
I copied the kernal from the SD card image I have for the RPi and it now seems to be running. just need to get VNC to connect to it now! – G-. May 12 '12 at 16:49
Sorry I had to accept John's answer as it is so much simpler. Thank you for your help! – G-. Jun 2 '12 at 11:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.