Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've seen some suggestions by using gconf-editor but it doesn't seem to work anymore. The option may have been removed (see).

Is there another way to increase Totem buffer size so when I see a video trough LAN it doesn't lag?

I'm using Totem Movie Player 3.0.1 with GStreamer 0.10.35 in a updated Ubuntu 11.10 machine with 3.0.0-16-generic Linux kernel.


I tried to make a file /etc/gconf/schemas/totem.schemas and ~/.gconf/schemas/totem.schemas but Totem doens't seem to care for them.

share|improve this question
I would be interested in this as well. – user55325 Mar 12 '12 at 1:39
I would like to at least upvote every answer but I don't have enough reputation yet. Sorry. – desgua Mar 15 '12 at 14:27

try adding this back to your totem.schemas (edit the default to your preference)

    <locale name="C">
      <short>Buffer size</short>
      <long>Maximum amount of data to decode ahead of display (in seconds)</long>

you may also be able to modify /schemas/apps/totem/buffer-size directly

share|improve this answer
I tried to create ~/.gconf/schemas/totem.schemas and /etc/gconf/schemas/totem.schemas with no success. Am I doing something wrong? – desgua Mar 15 '12 at 14:17

This issue was raised in Bug #108623 : totem isn't buffering correctly.
Although dating from 2007, this bug was never marked as fixed.

Another Bug #75201 : Bad cache managing in video playing claims :

Closing this bug as totem 2.17.91-0ubuntu2 works fine now

Which version of Linux/Totem are you on ?

The last article also says :

For a network play it's not buffer-size but network-buffer-threshold.

share|improve this answer
Try also using network-buffer-threshold. – harrymc Mar 15 '12 at 11:44
Thank you. I've update the question. I am not experiencing a bug as Totem works fine. I would like to increase the buffer size but those configurations aren't available anymore. – desgua Mar 15 '12 at 14:16
You are right! The Totem-3.2.1 chapter says : "There are no configuration files that need to be directly edited. Configuration is accomplished by setting the desired values in the various menu options accessed via the totem graphical interface". So that's where you need to find this setting. Make sure to search for a network buffer. If you can find nothing in the menu, then your only option is to recompile Totem with your buffer size, but I can't help you there. – harrymc Mar 15 '12 at 14:29
The above doesn't seem to be totally correct. I found more info in Old VS. Python configuration file syntax that may lead you to the new configuration files. – harrymc Mar 15 '12 at 14:32
Thank you very much for clarifying this. If no one else post a solution that works, I will give you the bounty. Best regards. – desgua Mar 15 '12 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .