Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I haven't been able to apply any color scheme to iTerm2.

It looks like that the Basic Colors are applied, but the ANSI Colors are not (as shown in Preferences>Profiles>Colors).

Using Mac OSX 10.7.2. Any help?

share|improve this question
    
So there is a bug in iterm2.... Use default item provided.... –  ZaB Mar 11 '12 at 22:10
    
Really any color you select? What is the Terminal Type selected in Preferences » Profiles » Default » Terminal under Terminal Emulation? –  slhck Mar 11 '12 at 22:21
    
@slhck Report Terminal Type: xterm-256color –  Panagiotis Panagi Mar 12 '12 at 12:51
    
Try changing it to xterm and see if that works. –  slhck Mar 12 '12 at 13:05
    
@slhck Changed to xterm and xterm-new and restarted. Nothing works. –  Panagiotis Panagi Mar 12 '12 at 13:14

3 Answers 3

up vote 23 down vote accepted

I've been having the same issue and this is what seems to have solved it:

In your .bash_profile set CLICOLOR before setting TERM:

# Set CLICOLOR if you want Ansi Colors in iTerm2 
export CLICOLOR=1

# Set colors to match iTerm2 Terminal Colors
export TERM=xterm-256color

save bash file and source:

source ~/.bash_profile 

Then, in your iTerm2 Preferences > Terminal > Report Terminal Type, set to either xterm-256color or xterm

Close iTerm2, restart it and type ls. That did the trick for me.

Good luck.

share|improve this answer
    
it works very well for me –  ajreal Apr 22 '13 at 19:27
    
exporting the CLICOLOR finally made colors appear in iTerm2. The preference had xterm-256color set, I wonder why this was tripping it up. –  mguymon Feb 12 at 21:18

this is a really old question, but make sure your Preferences->Colors->Minimum contrast setting is not at the max... if it is and you've done what is suggested above, slide it to a lower setting and you should see the colors appear.

share|improve this answer

I had the same problem and found a solution: Profiles -> Colors -> Minimum Contrast. If it's high, then you only get black and white.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.