Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I get rid of the Speedbit address that has been set as my Firefox home page? I am unable to change my home page to Yahoo, Google, etc. through usual methods. How can I fix this?

share|improve this question

I do not have experience with SPEEDbit, but in general, to restore Firefox's home page settings:

  1. Go to about:config

  2. Reset (Right-click -> Reset) the following preferences:

    • startup.homepage_override_url
    • browser.startup.homepage


I suspect that you could also do a search (filter) for speedbit in about:config and reset any related preferences. This would hopefully restore other hijacked preferences!


Warning: the following was performed by a professional in a secure, virtual test environment. Do not try this at home.

To provide a more complete answer, I went ahead and installed the SPEEDbit Download Accelerator Plus (DAP) and their "recommended" additions or settings: Search Predict, Video Downloader, and Video Accelerator.



Note: You can disable these add-ons by going to about:addons.

Now, this is what my new Firefox profile looks like:

firefox profile

As you can see, SPEEDbit added a toolbar, changed my home page and search bar.

Let's try to reset the home page using the GUI (Options > General > Startup):

reset home page

Note: if you cannot restore the home page using the GUI, you can do so by resetting the following preferences in about:config:

  • pref.browser.homepage.disable_button.restore_default
  • browser.startup.homepage

It seems to have worked...


However, Download Accelerator Plus and Video Accelerator are still running:


So, let's restart the computer to see if our change persists.

SUCESS! (I would post a screenshot, but it would be identical to the one above. You'll have to trust me.)

Your question only covered the home page, but I want us to poke around about:config to see what else SPEEDbit has got its dirty little paws into.


So, to restore any other hijacked preferences, reset the following:

  • browser.startup.homepage_override_url
  • keyword.URL

Your profile should now look like this:


And finally, if you want to hide the Video Downloader toolbar, uncheck:

View > Toolbars > SpeedBit Video Downloader



So, after one last reboot with Download Accelerator Plus and Video Accelerator still running, the search bar and keyword.URL were hijacked again. Is it one of the add-ons? Is is the aforementioned programs? Time to investigate. I'll skip the details and simply post my findings... >:(

  • Disabling all three add-ons was unsuccessful. The preferences were hijacked again after a reboot.

  • Unchecking Mozilla/Firefox integration under Download Accelerator Plus's Options > Advanced was unsuccessful.

    browser integration

  • Disabling Download Accelerator Plus or Video Accelerator from auto-starting was unsuccessful.

  • Disabling the Video Accelerator service from auto-starting was unsuccessful.

The only thing that stopped Firefox's preferences from being hijacked was to uninstall Download Accelerator Plus. Once you've uninstalled the software, retracing the above steps should work properly.


If you want my personal opinion on the software, I would advise you not to use it. Due to it's rogue nature and malware-like appearance (ads, ads, and more ads), I have a hard time believing "265 million users" were satisfied with the product.

share|improve this answer
Great answer @iglvzx, perhaps you should consider writing about it for the SU blog? – Ivo Flipse Mar 13 '12 at 9:02

You might have installed toolbar or other software from speedbit and that is the reason you can't reset your home page.

Check if you have any software or toolbars from speedbit installed. if you have, check in its settings to see if it is resetting your home page.

If you don't have any such software then it could be problem with browser. try the steps @iglvzx has specified.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .