Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed a PCI video card (Nvidia GeForce FX 5200 128MB PCI from EVGA) into my Ubuntu 8 system (on a Dell e510 machine) which was previously running on board video. When i booted the system, disabled the onboard vga in the system BIOS, which allowed the PCI video card to output video. However, my system hung on startup. I imagined it had to do something with the drivers, so i tried to edit the /etc/X11/x.conf file to remove any drivers, but it looks as if everything is generic, so i'm not sure what's wrong.

I even tried to use the boot manager to remove 'splash' and 'quiet', and added 'verbose' to the kernel starting, but honestly, i'm not too familiar with Ubuntu or the new X system.

What could i do to get the system to be a default state where it'd accept & boot from a PCI video card. I'd really like to stay away from having to re-install the machine.



Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option      "XkbRules"  "xorg"
    Option      "XkbModel"  "pc105"
    Option      "XkbLayout" "us"

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
    Option      "CorePointer"

Section "Device"
    Identifier  "Configured Video Device"

Section "Monitor"
    Identifier  "Configured Monitor"

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"

Section "ServerLayout"
    Identifier  "Default Layout"
    Screen      "Default Screen"
share|improve this question
up vote 1 down vote accepted

First search for nvidia using 'apt-cache search nvidia' command. Then install the newest version of nvidia driver. In ubuntu 9.04 it's nvidia-glx-180. Then run the nvidia-xconfig command in super user mode(AKA sudo). then restart.

Hope this will work for you.

share|improve this answer
Thank you, you're awesome! – Roy Rico Sep 13 '09 at 17:45

Still sounds like some sort of driver conflict. Not being as spiffy with x.conf as I'd like to be, I'm not sure what to check next. Have you tried looking in the Ubuntu support forums? I've found tons of valuable advice there.

share|improve this answer
i've seen some suggestions there, but they all say to look at the x.conf, and I can't see anything wonky. :( – Roy Rico Sep 12 '09 at 9:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.