Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I install this extension?

Whenever I click it, a "Unconfirmed xxxxx.crdownload" file is created in the default download directory (in my case, the Desktop), instead of the expected Save As dialog or extension installation confirmation.

Bug report.


EDIT: After disabling New Downloads UI in about:flags, everything's fine.

share|improve this question
    
I had no problem downloding the file. I suspect you have something installed blocking you from downloading the file. –  Ramhound Mar 12 '12 at 11:38
    
I had this happening to me on Chrome using Linux a week or so ago when trying to install a user script. I tried it a couple days later (after a Chrome update) and it was working again. –  Dracs Mar 13 '12 at 6:18

2 Answers 2

up vote 2 down vote accepted
  1. Download the CRX file using an alternative browser (i.e. Firefox) and extract it to a folder using a program like 7-Zip.
  2. Open up the extensions page and enable developer mode.
  3. Click on "Load unpacked extension..." and select the extracted folder. Load unpacked extension...
share|improve this answer
    
Problem is, I can't download the CRX file. (Although, it just occurred to me that I can download it with Firefox.) –  muntoo Mar 12 '12 at 23:58
    
@muntoo yes you could . –  HackToHell Mar 13 '12 at 11:27

This happens when the default download folder does not exist.

It's expected for the file to add the ".crdownload" extension while it's downloading. This extension means that the download isn't complete yet. When the download's complete, it should remove this extension, and moves the file to the default download folder.

Set and existing download folder in:
Settings -> Show advanced settings... -> Downloads -> Download location

share|improve this answer
    
Hey Ahmed. :) The problem was with the "New Download UI" being enabled in about:flags. I forgot to edit the question after I figured this out. –  muntoo Jun 27 '12 at 7:19
    
Hello muntoo. I had the same problem this morning while updating an extension. First I found this question, then found the discussion about issue <a href="productforums.google.com/forum/#!topic/chrome/…;. After playing with those settings a little, I was able install the extension. EDIT: How do we create links in comments? :) –  hkBattousai Jun 27 '12 at 14:33
1  
[Text here](http://example.com) (You can click the help button while making a comment for more info.) –  muntoo Jun 27 '12 at 20:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.