Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to use SQLDeveloper with files that are fairly large. However, performance is sluggish (at best) due to a lack of memory.

Assuming that it is a Java app, how can I increase the size of memory allocated to the VM?

share|improve this question

This post has useful details on where to tweak the JVM settings.

Essentially, look for ~/sqldeveloper/bin/sqldeveloper.conf and in that, look for:

AddVMOption -XX:MaxPermSize=128M

share|improve this answer

Edit your sqldeveloper/ide/bin/ide.conf file and change the following two lines:

#
# If you are getting the 'Low Memory Warning' Message Dialog while running
# JDeveloper, please increase the -Xmx value below from the default 768M to
# something greater, like 1024M or 1250M.  If after increasing the value,
# JDeveloper is no longer starting up because it fails to create a virtual
# machine, then please reduce the modified -Xmx value.
#
AddVMOption  -Xmx1024M
AddVMOption  -Xms512M

The other answer regarding use of -XX:MaxPermSize in sqldeveloper/bin/sqldeveloper.conf is outdated and would not work in the recent versions of sqldeveloper. Using that would result in following sqldeveloper message on startup:

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=1024M; support was removed in 8.0

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .