Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am testing hunspell in the command line with a swedish dictionary. The input in the interactive mode replaces all special characters (for example å ä ö) with blanks before spell cheching.

Hunspell 1.3.2
sjögräs
& sj 15 0: SJ, aj, dj, sk, s, j, sej, sju, sjö, sjå, sa, se, ej, st, si
& gr 15 3: ge, g, r, ger, gir, gro, gör, grå, går, gry, er, nr, dr, go, kr
*

sj gr s
& sj 15 0: SJ, aj, dj, sk, s, j, sej, sju, sjö, sjå, sa, se, ej, st, si
& gr 15 3: ge, g, r, ger, gir, gro, gör, grå, går, gry, er, nr, dr, go, kr
*

As you see, the prompt's encoding is working, showing å ä and ö both in the input and the output.

Piping gives the same result:

echo sjögräs | hunspell -d sv_SE

I have tried to give different options to hunspell, including -i UTF-8, -i UTF-16, and keeping the aff file's SET ISO8859-1. Nothing worked.

The same thing happens with french:

C:\Users\gauthier>echo résultat | hunspell -d fr-moderne
Hunspell 1.3.2
*
& sultat 2 2: sultan, rAcsultat

with in addition problems with the output.

I compiled hunspell in MinGW and moved the resulting needed files to somewhere in my path, but I don't think that this information is very relevant.

How do I make hunspell recognize special characters on its input?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.