Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have public and private keyring files in my .gnupg directory (pubring.gpg and secring.gpg). I want to create a new keyring trustedkeys.gpg, also in .gnupg, to which I can add other people's public keys.

How do I create this new keyring?

share|improve this question
2  
The convention is to have all keys in your pubring. Trust is marked using GnuPG's own settings. – grawity Mar 12 '12 at 22:19
    
gpgv expects signatures to be in trustedkeys.gpg. – rlandster Mar 13 '12 at 3:57
    
Can you work around the problem by making a symlink from trustedkeys.gpg to pubring.gpg (or trusteddb.pgp)? – IQAndreas Sep 21 '14 at 15:30
    
@grawity conventions are just that - conventions. the OP out there will know better the needs at hand. – n611x007 Oct 24 '15 at 7:20
gpg --keyring pubring.gpg --export KEY > /tmp/exported.key
gpg --no-default-keyring --keyring=path/to/new-keyring.gpg --import /tmp/exported.key

If you want the keyring to also be used by GPG by default from then on, as you say, omit the --no-default-keyring switch.

Find more information in gpg(1) manual under --keyring option.

share|improve this answer

tested with gpg (GnuPG) 2.0.26:

gpg --no-default-keyring --keyring trustedkeys.gpg --fingerprint

beginners' hint: you can use any filename not just trustedkeys.gpg.

it will say gpg: keyring ``</path>/.gnupg/trustedkeys.gpg' created

to use:

gpg --no-default-keyring --keyring trustedkeys.gpg <your-gpg-commands-here>
share|improve this answer

gpg --export KEY1 KEY2 > trustedkeys.gpg for public keys and:

gpg --export-secret-keys KEY1 KEY2 > trustedkeys.gpg for complete keys (including private part).

Where you can supply (partial) fingerprints for KEY1, KEY2 etc.

share|improve this answer
    
gpg: invalid option "--export-keys" gpg (GnuPG) 2.0.26 – n611x007 Oct 24 '15 at 6:57
    
@naxa I'm sorry, my mistake, I corrected the answer. – ufotds Oct 24 '15 at 9:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .