Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I start a new session on Ubuntu 9.4 I need to run jockey-gtk to enable my wireless networking card:

jockey-gtk -e firmware:b43

jockey fails if I try to run it from rc.local, even if I try to set DISPLAY first. Is there some way to run this command automatically on startup?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

jockey-gtk does not work outside of an X environment. This was recently fixed with the addition of jockey-text, a command-line text frontend. Check if you can get the package for Karmic containing this fix to work for you. Launchpad bug report with fuller details: Command-line interface doesn't work without X

share|improve this answer
add comment

I had to add

deb http://us.archive.ubuntu.com/ubuntu/ karmic main restricted

to /etc/apt/sources.list and then run apt-get install jockey-gtk to get the version with jockey-text. After I did that, adding the line jockey-text -e firmware:b43 in \etc\rc.local successfully enabled my wireless card when my session started. Then I removed that line, or else apt-get update will install karmic.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.