Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Proprietary Nvidia (290) on gentoo here.

I'm running Nvidia TwinView with two 1680x1050 monitors here. Now I want to hotplug between HDTV and one of the monitors. Almost good, but since Nvidia reads the EDID information of the monitors and sees the maximum resolution of 1680x1050, it won't allow 1920x1080. "Detect displays" of nvidia-settings doesn't do anything. My only option this far is to restart X, but this is highly unpreferable.

I already discovered that something towards my liking can be done with MetaModes, but it doesn't allow larger resolutions either.

I guess I have to drop the EDID information and specify modes manually. However, TwinView hasn't liked my offerings thus far.

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

# inputdevice junk removed; it's overridden anyway

Section "Monitor"
    Identifier     "CRT-0"
    ModelName      "Acer P221W"
    HorizSync 31-84
    VertRefresh 56-77
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "MetaModes" "CRT: 1680x1050 +1680+0, DFP: 1680x1050 +0+0; CRT: 1680x1050 +0+0, DFP: 1920x1080 +1680+0"
    #Option    "UseEdid" "false"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question

1 Answer 1

up vote 0 down vote accepted

After enough tweaking I was able to get 1920x1080 as an option for CRT output. Why it didn't apply for DVI, beats me. So this is only a 80% solution: now I can swap monitors on the fly but using suboptimal VGA. I'm done tweaking this one and ordered a modern GT520 that has three connectors.

Here's the current xorg.conf. The custom modes for my monitors I obtained using the parse-edid software.

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "DFP-0"
    ModelName      "Acer P223W"
    Option         "DPMS"
    HorizSync   31-84
    VertRefresh 56-77

    Mode    "1920x1080"
            DotClock        148.500000
            HTimings        1920 2008 2052 2200
            VTimings        1080 1084 1089 1125
            Flags   "+HSync" "+VSync"
    EndMode
    Mode    "1680x1050"
            DotClock        146.250000
            HTimings        1680 1784 1960 2240
            VTimings        1050 1053 1059 1089
            Flags   "-HSync" "-VSync"
    EndMode
EndSection

Section "Monitor"
    Identifier     "CRT-1"
    ModelName      "Acer P221W"
    HorizSync 31-83
    VertRefresh 56-75
    Option "DPMS"
    Mode    "1680x1050"
            DotClock        146.250000
            HTimings        1680 1784 1960 2240
            VTimings        1050 1053 1059 1089
            Flags   "-HSync" "-VSync"
    EndMode
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "DFP-0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "MetaModes" "CRT: 1680x1050 +1680+0, DFP: 1680x1050 +0+0; CRT: 1680x1050 +0+0, DFP: 1920x1080 +1680+0"
    #Option        "UseEdid" "false"
    #Option         "ModeDebug" "True"
    SubSection     "Display"
        Depth      24
        Modes      "1920x1080" "1680x1050"
    EndSubSection
EndSection
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.