Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There are several threads regarding accessing host's localhost from a guest OS. None attracts my specific problem, therefor IMHO this question isn't a duplication.

I did follow all the steps appear on other threads. My default gateway is 192.0.0.1. Pinging to it is positive, opening this url in browser brings me to the router login page. Adding my localhost port brings a 502 http error .

I'm running my VM in bridged mode, without "replicating physical network connection state"

I tested the traffic using fiddler, and he responded that "No connections could be made because the target machine actively refused it"

I disabled firewall in both sides. I also disabled proxy in IE browser, and ran ipconfig /release & /renew.

Than I thought- lets try accessing my pc from my vmware. I see it in my network but the folder isn't accessible. Other yes. Other people here in my job can access my pc, without any problems.

I have no idea where more to go or to try. Hope someone here might be able to help me. Thank you!

Other posts regarding this matter:

share|improve this question

closed as too localized by Mokubai, Scott, Sathya Jun 13 '13 at 4:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
what is your host machine's ip address ? –  Shakehar Mar 13 '12 at 15:07
    
Do you have a web server running on the host machine in the first place? –  Chris Mar 13 '12 at 15:09
    
@Shakehar- my host IPv4 default gateway is 172.0.0.1. –  neoswf Mar 13 '12 at 15:19
    
@Chris- Yes. My VS2010 is running at localhost:40365. –  neoswf Mar 13 '12 at 15:20
    
I forgot mentioning that I'm running my VM in bridged mode, without "replicating physical network connection state" –  neoswf Mar 13 '12 at 15:21

1 Answer 1

If you're running in bridged mode, your guest won't be on the same IP as your host. They will each have separate IP addresses. Localhost will only refer to the machine it is being called on.

Post ipconfig /all or ifconfig from both guest and host so we can see what we're dealing with.

share|improve this answer
    
Thanks Jim for your reply. I have uploaded print screens of the two ipconfigs, cause pasting them here isn't that readable and with bad text format. 1. The Vmware link 2. My host ipconfig link –  neoswf Mar 16 '12 at 16:09
    
So it looks like you should be able to access each server at 172.0.0.22 and 172.0.0.29, respectively. The 192. network is not shared between both machines. –  Jim G. Mar 16 '12 at 18:16
    
Hi @jim & thanks for your response. It doesn't work for me. I'm pinging successfully 172.0.0.22, but in the browser the page doesn't load. (I've tried to replace the ip with localhost in the host file, with no success). I opened Fiddler and got error 502 from the browser. –  neoswf Mar 19 '12 at 12:36
    
Fiddler also gives this error - [Fiddler] The socket connection to 172.0.0.22 failed. A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond . –  neoswf Mar 19 '12 at 12:36
    
If fiddler is the issue - This checkbox is checked for me blogs.msdn.com/b/mikeormond/archive/2008/01/29/… –  neoswf Mar 19 '12 at 12:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.