Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Update 2012-03-27: It might be the physical connection from my cable modem to my provider. The cable provider says he's seeing disconnects of the modem, and they're sending a technician. (Also, please consider upvoting to help a low-rep user like me pay for his bounty...)

My setup: I have a PC with a Gigabyte GA-MA78S2H motherboard (Realtek Gigabit wired Ethernet on-board). I have the latest drivers (at least the latest driver for the NIC.

I'm connecting via an Edimax BR-6216Mg (again, wired connection), to a cable internet provider (infrastructure provider is HOT, ISP is Bezeq Intl.).

For some reason I experience short periodic disconnects and reconnects. Specifically, Skype disconnects, tries to connect, succeeds after a short while; incoming SFTP sessions get dropped; using a browser, I sometime get stuck in the DNS lookup or connection to the website and a page won't load. A couple of seconds later, a reload works.

All this happens with Windows XP SP3. With Windows 7, it also happens. (When I initially wrote this question I didn't notice it.)

ipconfig for my adapter:

Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Physical Address. . . . . . . . . : 00-1D-7D-E9-72-9E
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . :
    DNS Servers . . . . . . . . . . . :
    Lease Obtained. . . . . . . . . . : Saturday, March 10, 2012 8:28:20 AM
    Lease Expires . . . . . . . . . . : Friday, January 26, 1906 2:00:04 AM

A result of some tests a couple of the disconnects:

C:\Documents and Settings\eyalroz.BAKNUNIN>nslookup

DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address Timed out
DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address Timed out
*** Default servers are not available
Server:  UnKnown

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out

C:\Documents and Settings\eyalroz.BAKNUNIN>ping

Pinging with 32 bytes of data:

C:\Documents and Settings\eyalroz.BAKNUNIN>tracert -d

Tracing route to over a maximum of 30 hops

  1    <1 ms    <1 ms    <1 ms
  2     *        *       11 ms
  3    14 ms    13 ms    14 ms
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *       47 ms
  7    31 ms    27 ms    32 ms
  8    15 ms    14 ms    16 ms
  9    15 ms    15 ms    11 ms
 10    13 ms    29 ms    31 ms
 11    35 ms    15 ms    18 ms
 12    22 ms    22 ms    16 ms

I usually ping (which is not at my ISP) with 15ms response time and no losses.

Things I've done/tried:

  • [2012-03-26] I replaced the cable; I thought that made a difference, but the disconnects were back a while later, so that wasn't it.
  • Updated the NIC driver.
  • Tried reducing the MTU (used a utility called Dr. TCP); there was no effect.
  • I updated my board BIOS revision (which caused all the HW to be "reinstalled" or re-identified - successfully).
  • I installed another NIC, and tried switching to it - same effect with the on-board NIC.
  • A while back I tried another router (although it was an Edimax model) - same problem.
  • Connected the computer directly, with no router. Same problem.
  • ping -t to the router ( gives pongs, nothing is lost, and time is < 1 ms almost always (sometimes it says 1 or 2 ms). This is the case also during the disconnects.
share|improve this question
What is shown in your system and application event logs for the timeperiods when you experience disconnects? – Jeremy W Mar 14 '12 at 2:00
@JeremyW: I haven't kept exact record of the times, but I do see a lot of Event 1012 "Remote session from client name a exceeded the maximum allowed failed logon attempts. The session was forcibly terminated." in the System log. – einpoklum Mar 14 '12 at 18:51
up vote 2 down vote accepted

You seem to have tried about anything local, as well have proper working DHCP and DNS settings. matches, which appears to be a locally available DNS server not accessible from the outside.

Thus, the only thing left to do is to check up with your ISP, having them look in their logs or monitoring your connection over an extended period; this will help you to divide and conquer the possible locations and come to an eventual conclusion.

By the options you listed it's most likely the connection between the ISP and the modem, or the connection between the modem and the router. The router and everything beyond that have been excluded, except for the acteal motherboard itself as well as certain third-pary hardware that could have an influence; if calling the ISP doesn't resolve the problem you could make an at trying to disconnect as much as possible to see whether that helps.

As long as you try to divide and conquer, excluding things that are verified to not cause the problem allows you eventually get to the cause of the problem. Read more about it on the Super User blog...

share|improve this answer
I followed your advice, and called my ISP, or rather my infrastructure provider (which comes between me and the ISP). They see repeated modem disconnects and sending a technician. Hopefully that's the issue... we'll see in a couple of days. – einpoklum Mar 27 '12 at 17:04
ISP technician replaced the modem as faulty. Thanks and enjoy your bounty (won't add much to your already very high score...) – einpoklum Apr 1 '12 at 15:02
@einpoklum: It adds some more with an upvote and accept mark, easy to forget about them. They should make it so a bounty does that automatically. I'm actually trying to chase the nearest higher person on this page every time, which keeps me answering stuff around here... :) – Tom Wijsman Apr 1 '12 at 16:29

Boot from a Live Linux distribution and see if the problem persists - for example Knoppix, Ubuntu, DSL, Slax etc.

share|improve this answer

The issue your having is an old issue with Windows 7. From the Windows 7 perspective, the problem came to be after a buggy Network driver was initally rolled out. However this has been resolved with the current service pack. However the easiest way to revert this update and go back to the more stable driver is to perform a driver rollback. Windows Key + Pause break, then device manager, click on your network adapter, (if you have a wired and a wireless, make sure to select the one your using), then right click and select properties. Go to the Driver tab and select Roll Back Driver. Depending on which Service Pack your using with Windows XP, this option might exist their as well. After you get this resolved make sure you acquire the available Windows updates.

share|improve this answer

You are behind a router... How many connections are being fed?

Is there any chance that a collision storm might be occurring? When you can't reach external sites, can you still reach an internal IP address?

Have you turned off power saving for the NIC? Could it be that the NIC is being put to sleep, and it's taking a few moments to come back up to "awake" status?

share|improve this answer
Currently it's just one computer behind the router; sometime it's two but I'm seeing the issue with just the one. – einpoklum Mar 27 '12 at 16:32

It can be router related problem. If you can switch to another please do the tests. If not, in windows xp, try delete all NICs from device manager, and do 'refresh' to let the system install all hardware. No need to play with mtu. When this happen you you have inromation 'network cable disconneted' ?

  • When problem happen ping -t and see if you have pongs, if yes, that could be a problem with yours isp
  • Try update the motherboard bios, i have had problems with nics on laptop and it do the tirck; sience its a PC you can still do it
  • Ghost your xp, and reinstall windows for tests, maybe you have catched up some bad software
  • Replace your ethernet cable or clamp the plug very hard just in case :)
share|improve this answer
ee my edit above. I can't really try reinstalling XP at least for now, although if I have no choice then I will. Will try another cable... – einpoklum Mar 23 '12 at 18:51
Well, turns out it wasn't the cable after all. – einpoklum Mar 26 '12 at 14:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .